SST Exclusivity Issues (asio4all)


this might not be really a GP issue, but maybe someone has experience with this kind of problem.

Until recently, I ran GP on a Thinkpad Yoga 12. In ASIO4ALL I had this Realtek HD Driver, worked like a charm - audio for GP was exclusive, latency was low. As interface, im using a Radial USB.

Now, I switched to a Thinkbook 14s Yoga. In asio4all, I now have to use a “Intel Smart Smart Sound Technology for USB Audio” to get it working. Problem: Latency is around 10ms (too high for me) and sound is not longer exclusive, which gives me a risk of error sounds on a gig.

Does anyone has any experience on what I could do?

Im on asio4all 2.14 and followed
The newer BETA versions didn’t work at all for me, claiming it didn’t work “beyond reason”.

Why don’t you use an Audio Interface. I never could use Windows without an Audio Interface due to latency. Regarding the ASIO4ALL it is also increasing the latency with regard to my Audio Interface driver.

By the way, which GP version are you using?

You seem to use the Radial Engineering USB interface, but this doesn’t support ASIO natively, so you’d have to use ASIO4ALL as a crutch…
I don’t get it why you use this “Intel Smart Sound” thing in ASIO4ALL and not the Radial interface?
But anyways…
My recommendation would be: Get rid of this ASIO4ALL crap and get rid of the Radial interface and buy an actual soundinterface which comes with a proper and native ASIO driver!
This should instantly solve your sound problems.

The cheapest one i would go for is this one:

(I also have the bigger one UMC404HD and it works great and sounds absolutely ok)
If you have a bigger budget, go for Focusrite or Motu, or RME.

1 Like

Well, I do use the Radial Engineering USB interface. The latency around 10ms was not with my old laptop, so I really doubt thats the problem here…

GP 4.0.54!

Actually I got rid of my “proper” UR22 for the more expensive radial, which does exactly what I need: Isn’t instant dead when droped on the floor, awesome sound quality, USB to XLR and thats it. Was really satisfied with it until the new laptop…
(Meanwhile, the UR22 had a higher latency with the Steinberg ASIO than asio4all, so was used to use that anyway…)

As told, I really doubt it’s the interfaces fault as it worked perfectly with old laptop…

This image shows that Im actually trying to use the Radial, but it’s somehow mapped to that SST crap…

I have a UMC404HD and it works great. Probably not as fancy as a Scarlet 4i4 but it does the job and for about 1/2 the price.


1 Like

Turn them off - Turn off Windows sounds (free e-book).

By the way +1 for a dedicated audio interface.

1 Like

Yeah, I have the windows error sounds turned off - still a risk on stage to have not exclusive access, right? You never know what pops up… YouTube Video starting in Background or something stupid :smiley: I really liked the exclusive access.

By the way, I really would love to know more about ASIO and why all of you seem to be a fan of “real” sound interfaces as opposed to my beloved Radial, which I up to now thought was the perfect solution. Any tips where I could learn more about that?

When you optimize your PC, there can’t be stupid things :slight_smile:

From the free e-book: Audio drivers

Sorry Ididn’t notice the Radial is an audio interface, I tought it a built-in audio chip. But personally, using an audio interface with Windows, I would never go for a Brand which doesn’t offer a specific ASIO driver and even a multi-client ASIO driver. It seem it is not the case for Radial Engineering. In my opinion, ASIO4ALL is a generic driver, which is for example, absolutely not at the level of the driver delivered with my RME audio interface. It adds a terrible latency to me. I’m pretty sure your latency is even over the 10ms displayed in your GP audio settings when using ASIO4ALL. You could try to measure it with the GP measurement function. However, you could reduce your latency by using a buffer of 256 which seems to me a good compromise between latency and audio glitches.

Because Windows regular audio driver are not adapted to real time audio.

Your "beloved Radial’ IS a real audio interface. But personally, not one I would consider for using with Windows because of the lack of an high end proprietary ASIO driver.

Having said that, you shouldn’t get a worse latency than on your previous PC and this is for sure related to your ASIO4ALL configuration which doesn’t seem to be appropriate. Nothing to do with a specific version of GP!

Start to try to reduce the audio buffer size a bit.