Song part do not send MIDI Program Change to external Keyboards

I’m currently working on a setlist. In principle, it already fits quite well. Now I would like to have my Nord Stage Piano switched to the right sound by Gigperformer.

So I put the output of the setlist on the Nord in the central control. If I now store the program change in a SONG, this also works directly and without errors.

Now I have found the same option in the “Song Parts”. Here you can also store a MIDI program change in the same way. If I enter the same parameters here, nothing (meaningful) arrives at the Nord. Where is my thinking error?

1 Like

Do you set it here?

or here?

On the first picture

Ok, that is the pc message the song part reacts on.
When you want to send out you have to put it into the 2nd picture.

1 Like

I have tested it, so it’s working Thanks.

What I do not able todo is a bank change in the Nord. I can only make a Program Change. this I only can make with the option in the first picture

How can I do that?

Bank changes are cc32 and cc0

So I tried a lot and it works fine.

One situation is not working.

I am setting the NORD by entering the SONG. In the song part I am adding the slot change (cc68 0 or 127). It is not working.

When I make the same midi block in the next song part again, it is working.

When I have a look on the MIDI monitor it seems like gigperformer will first send the Midi Controls of the song part, followed by the midi signals of the Song.

Can anybody give me a proof of that ?
Can I change the behaviour?

What is the issue when that is done this way?

The slot selection in the Nord did not take place

Try to send out all messages from the song part and to not send any message from the song.

Thanks this is working , I have to switch off the midi send by entering the song.

1 Like