[Solved]No audio input with Gig Performer on OSX Mojave (Microphone Access Issue)

#1

Hi folks!

My music I/o, even though it appears to be properly connected and recognized as before on gp 2.x.x, does not receive any sounds on gp 3.

No tuner recognition either. As the setup currently runs, Logic X and MainStage pick it up right away.

The I/o is a UA Apollo twin thunderbolt into a MBP, same as when running gp 2

Thanks in advance for any tips, etc.,
-J.

#2

Hi there,

Could you explain this a bit more. Are you talking about your audio interface? If you run GP2 it all works, but then when you start GP3 it tells you that the interface is not connected? Is that what’s going on?

Which tuner are you referring to? The internal GP tuner? What does it mean that there is no “recognition”? Sorry - I’m just having trouble understanding exactly what you mean.

Once we have more informatio - we can try to figure out what’s going on.

#3

Hi!

1: Well, everything on gp3 indicates it is connected, all the right parts of the gp3 menus say my I/o is connected correctly, and it knows when the I/o is unplugged, or turned off, etc. However, no sound or indications it picks up any audio. To be fair, I did not try the earlier version (2.x.x) after this issue and I will tomorrow to rule this out, but it never had been a problem.

2:I do mean the gp 3 tuner.

As far as the troubleshooting guide goes, I’m 99% sure I’ve checked all the “shoots.” I have a sense there must be a “panic button” style of reset to get everything to talk to each other.

~J.

#4

If your interface is not sending any audio to GP then the tuner would not work. It cannot work unless there’s a signal coming in.

If GP can detect the interface connection/disconnection then the interface is connected.
The only thing I can think of is either your GAINS on the interface are set too low (if there is a control somewhere).

#5

I’ll double check the gains tomorrow or hopefully tonight. As I mentioned, Logic X and MainStage pick up the audio as it presently is. I’ll post results when I do. Thanks! -J.

#6

OK had some time to look into it today and try some other things.

I restarted my previous GP, and realized it is NOT gp 2x.x., but GP 1.8.3.4 (it always offers to upgrade but is never able to complete the process)

GP 1.8.3.4 works as well as ever, immediately picks up the instrument and i/o and all its features run great.

(Sorry for any confusion in the title of this thread)

The GP That is NOT working for me is GP 3.2.7. I will check the main site for updates and se if there is anything I can do to run it.

Thanks again for any help as Im really into this platform so far.

~J.

#7

Can you please explain exactly how it is not working? What happens when you run it? Note that GP 3 is not a free update from GP2 or GP1. It may be you were only running it in trial mode, in which case the audio will disconnect for a second or two every so often.

#8

It does not process any sounds; no tuner, nothing. Swapping “gigs” from 1.8 (works), to gp3 (doesn’t work).

Gp 1.8.x, all my other DAWs work, gp3 Indicates all the connections are correct and as mentioned in the troubleshooting guide. License says it is activated.

~J.

#9

When you open GP3 and go to Options->Audio Setup - is the correct device selected?
Maybe you are using a different device from the one you think you are using?

if you open GP3 and start a new gig, then insert a plugin instrument, connect it to the outputs 1-2 and then connect MIDI in into it. Open the MIDI in block and manual push some keys - do you hear anything? If not - is there any movement in the meter at the bottom right?

#10

1: yes correct device is indicated, as it is in 1.8, and other DAWs.

2nd paragraph. That is outside my normal usage, so I will look up what a plugin instrument is, etc and try it out.

Thanks again for everyone’s time.
~J.

#11

If your only usage is to connect a guitar to your interface - do you see any activity on any of the input meters at the bottom LEFT side of GP3 when you play your instrument?

#12

none. Also just tried my previous i/o, a scarlet 2i2, with no change. Do i need to delete and reinstall gp3?

#13

I connected to @Jaanus computer and it turns out that the solution was simple :slight_smile:
Gig Performer 3 did not have permission to access the microphone. It’s one of the new things OSX Mojave asks users so if you don’t allow it initially it blocks all input access.

To fix it - just got to Settings on your OSX, type in “microphone” in the search bar and select “Allow applications to use microphone” then make sure Gig Performer is enabled.

Thanks @Jaanus for allowing us to connect to his computer and debug this issue.