Solved ! Can´t send audio into GP...........weird problem / was all fine a few Days ago/ where to look for debugging?

i Can´t send any audio into GP ! ( M1 mac, big sur)

it was working fine a few days ago !!
i sent audio in thru loopback, fine.
i sent audio in thru my audio interface, fine. In fact have i used two different ones.

Now ? nada.
What i´ve donne/changed:
i use a TB2 Docking station, and i have to share this one now between two Macs,
and i used to swap my Audiointerfaces from computer to computer.
so it could be that i did not used same USB ports,
respecitvly changed the connection from: “thru a USB Hub” vs. “direct to mac” connection, finally the TB2 docking station was never the port for my AIs.

Also have i swaped forth and back in my audio settings in the mac, using this or that or a aggregate device as my main Audio source.

now, what can i do, where should i have a look ?
what would you do ?
( i´m aware of the Audio settings, for GP as well as on my mac / i tryed to resett things, or juggling forth and back)

my AIs are:
NI kore6 ( or so, the 6chanell one)
Behringer UMC1820

also, i can run audio into my NI 6 AI, it IS shown in Loopback, and it IS sent out thru loopback,
but its not coming into GP with “Loopback”…which was just working perfectly a few days back

I reinstalled GP3, and got GP on my M1mac running again for just a Moment.
( Loopback as the In device)

I switched then the audio interface seting again to see if the audio interface as the In device would work now too,
and since the audio In into GP is again no longer working. Regardless which device i select

audio interface as well as Loopback is working otherwise well.

Same porblem occours also on my second M1mac which was setup the last days,
based on a installation from the timemachine backup of the first M1mac.
same situation, all necessary Audio works otherwise well.

if there´s anything to do, would i be really thankful to know.
i also wonder if this could be a M1mac specific problem that i run now into…
(i´m aware that BigSur in M1 is not officially supported)

Check of GP is allowed to use the microphone in the OS Security Settings,

1 Like

Wow !
…and i just rejected the request from Reaper 5 minutes ago, which wanted to use the microphone in, haha :wink:

And: this is it ! …i can send again audio into GP3,…ahhh

You just saved my live Paul !

huuraaay !

1 Like

As of version 3.6, Gig Performer itself runs perfectly fine in Catalina. You will most likely be prompted to allow access to the Microphone and you must allow this .

----> and also written there:
The prompt is a little bit misleading,

Q: ( full OT)
how can i solve this problem now with Reaper. I installed it…and denied “microphone access”.
it is NOT shown in that security settings dialog where i could enable “microphone access”.
how can i make it appear ?