[solved] Button widget challenge

I need some help figuring this one out…

I just bought a new midi controller (Nektar T6), and I am trying to create a rig to map all my existing controls on my Nektar LX+ and switch to the T6 when needed.

All of my rackspaces are setup with button widgets that i use to turn parts on/off. I use drum pads (setup as CC toggle) on my LX+ to toggle the button widgets.

The T6 drum pads function differently than those on the LX+. On the T6, the pad strikes can be notes only, and I can set pad pressure as CC. On the T6, i setup a pad as
Note: Off
Channel: Global
Max: 127
Min: 0
Latch: Off
Pressure: MIDI CC
MIDI CC: 106

I mapped this in my new Rig as Pad1, and GP recognized it. However, when I am using Pad1 on the T6, it is not toggling my button… it is triggered with pressure, but does not latch. Also, even if it did latch, it is difficult to use pressure to toggle the button.

Any ideas for how I could setup my T6 drum pads to function as toggle buttons without having to redesign my rackspaces?

Did you create a new rig with the note messages assigned to your controls?

I created a new rig, but because I set Note to Off on the hardware, it mapped CC 106 to my Pad.

Why cant you map note messages?

That is good idea. Just tried that using a note that is too high to trigger audio in my VI’s. I am using F#8 now. I still have a compatibility issue though. I mapped the note off event for F#8 to pad 1. Now I need to figure out how to toggle the widget button without having to edit all of my rackspaces. My button widgets do not have “Treat momentary as latching” selected.

Now my hardware pad 1 is setup as
Note: F#8
Chan: Global
Latch: Off
Pressure: Off

And now, all i can do is enable the widget, but I cannot disable it. Once it receives the F#8 note off event, it becomes enabled, but pressing the pad after that does not change its state.

Also, it seems my VI is playing audio for note F8 if I map a pad to F8, so need to figure that one out too without having to edit my MIDI in blocks :frowning:

[quote=“andymcafee, post:5, topic:2256”];-
Just tried that using a note that is too high to trigger audio in my VI’s. I am using F#8 now.

When you map a note on to a widget then this note on will not be processed further.
So you can use whatever note you want (except you want play this note).

“Treat momentary as latching” is important when your controller always sends the same message but you want toggle the widget.
So I think you have to change the widget behaviour in your rackspaces.

Thanks. This works for me now. Unfortunately, I will need to edit all of my button widgets to treat momentary as latching in all of my rackspaces (about 150), but I will do it over time as I need them. I am now using Note On events for my drum pads, and I setup my other 2 midi controllers to function the same.

Thanks for the ideas.