[Solved] Been away, now nothing works

so, i’ve been busy the last half year, everything worked fine last time i used it, i open gig performer and it can’t find my line 6 helix, reinstalled the driver, windows says it works, i even here sounds thru my helix as i type to log in, i seem to be able to choose it as an output, but when i try input gig performer says… Error trying to apply settings!
Couldn’t open the input device!

help please

now it says…
The input and output devices don’t share a common sample rate,
both input and output are trying to be assigned to the helix

now it says…
error opening Primary Sound Capture Driver: Generic error

gig performer version 3.1.7

updated to 3.2.7, no change

Sounds like you have something else locking the Helix. Clearly something has changed in your configuration outside of Gig Performer. Maybe you updated something else, or did a Windows update, or a Helix update or something since you last used Gig Performer.

That probably means that you do not have the option “Allow apps to access your microphone” in your Windows Privacy Settings (I assume you’re using Windows 10)

i’ll try that, but i haven’t even looked at rather than turn anything on even, since the last time i used everything

how do i get to the windows privacy settings?

There’s no magic. Something had to have changed otherwise it would have just kept working.

https://support.microsoft.com/en-us/help/4027945/windows-change-privacy-settings-in-windows-10

also, when it does find helixs outputs, there’s only two instead of the usual 8, i think it was, i used 4 of them

so, i allowed access, it allowed me to enable it, no audio works thu, one guitar vi makes gurgling noises, that’s it, no midi guitar 2 or any synths, this thing is so very fucked, hundreds of hours of programing just shit the bed, shoulda bought a mac i guess, pc’s suck so hard

Hmmm, as I said, since it used to work, something has changed (and don’t discount possible hardware failure such as RAM, disk issues, etc).

You might want to try installing the latest Helix, reinstall GP and make sure you reboot your machine.

If you do in fact switch to a Mac and have all the appropriate plugins, you should be able to load your Windows gig files with little or no problems.

i have the latest helix driver

and reinstalled it

i think the helix driver used to show up as asio, now it says DirectSound as audio device type

it’s a brand new i7 asus computer, it works fine, something software wise is fucked

my favorite virtual organ is pc only i think

VB3 is pc only i think