Softstep 1

I work with Mainstage 3 & Softstep 1 & OSX Mojave without any problems. I decided to move to Gigperformer 3.8.0 and i can’t set it up properly. Is there anyone who work with GP3 & Softstep1?
Is it my fault or bad combination?

Hi @piotr,

welcome to the famiiy :wink:

Please tell me, what is Softsetp 1?

Did you enable Softsetp in the MIDI port otpions?

OK, you are working with GP3, so it should be visible.

Please consider to test GP4, many improvements.

Thanx, Hello,
Softstep 1 os older version of softstep 2
Zrzut ekranu 2021-07-5 o 10.49.55

Ok, so the softstep is recognized by GP.
What does the global MIDI Monitor window show when you press some buttons on your softstept?

1 Like

Just to chime in briefly…
@piotr Please tell us what you want to do with your Softstep controller or how you intent to use it (controlling widgets, switching rackspaces or songs…?)
Please consider to give us more information of your use case, this will make it easier for us to help you!
Thanks, and welcome to our community! :slight_smile:

Thanx for your help and patience.
I want to use softstep to switch on/off plugins , tap tempo, tuner, + one expresion pedal.
simple 1 rackspace guitar rig.
i’ve connected widgets with plugins it works but I can’t connect widgets with controller properly,
sometimes i works for one buuton, sometimes not.
Midi monitor shows me different things depends of softstep mode. hosted/stanalone.
hosted cc25 shows me as cc78 in GP and one touch gives me 4/5 lines of messages…
Standalone is more close to the Softstep Editor.
I’ll try to connect Arturia beatstep and I’ll tell you what is going on.
but finally I need foot controller


Well, currently Catalina GP4 and SS2 to be exact.
GP4 and GP3 work perfectly with both SS1 and SS2.
I have both GP3 and a SoftStep1 as backups and a Mojave partition if stuff needs testing.

Are you using Hosted or Standalone mode?

1 Like

hi, thanx, I try both but without success at the momment. but standalone looks more stable. and you?
with powered USB hub or not?

Standalone. No hub.

Testing my SS1 through my thunderbolt hub now. PC and CC messages received in GP. :slight_smile:

Standalone is more stable. With hosted you have to block the raw data from the softstep getting to your host. It must only see the processed output from the Advanced Editor. (see page 52 of manual)
This was impossible in Mainstage! Not tried with GP as I don’t need the extra message types…

thanx a lot. In Mainstage I work in Hosted mode without any problems. Good to know that it works for you. So I have to check my setup, maybe other Mac and i’ll be back with good news, I hope.
Which version of Editor you use for SS1? 2.04?

I only ever use Standalone mode.

What are you trying to do with Softstep?
Rackspace changes with PC?
Widget control with CC?

Widget control with CC

Just gave hosted mode a try.
Got most message types but not PC until I remembered to change these settings to Softstep Share.

CCs getting into GP no problem

thanx a lot.
a way better! still can’t conect expression pedal but there is a progress!
with arturia beatstep it took me 5 minutes…

Do you have the pedal set up as a source on the Nav pad? (on every bank you use) Check it has the correct output for Standalone/Hosted mode.

Hosted mode worked straight away for me :wink:

of course i didn’t!
this editor is very powerfool but you can’t miss any step…
so, this tip with softstep share was crucial!
thank you for your help and pacience
and for others too.