SIM-BP plugin by Quilcom will not install on my two Lenovo Thinkpad P16 Laptops (but it works fine for other people!)

EDIT 01/18/24: I hope you do not mind that I am resurrecting this thread. My band is doing a song that calls for electronic bagpipe. I would really like to get the SIM-BP working. It does not work (see specifics above) on either of my (almost duplicate) Lenovo Thinkpad P16s. (But it works for other people with Windows 11 machines and worked for me on my Dell Windows 10 machine).

Hello,

I am sitting in with a band playing Copperhead Road by Steve Earle.

After doing a bit of research, I downloaded and installed this plugin into my “old” Windows 10 laptop:

SIM-BP by Quilcom (Flowtoners(?)

It scanned fine in my Windows 10 laptop and sounded perfect for the song (electronic bagpipes).

So, then I downloaded/extracted/installed it into my new Windows 11 laptop and the plugin would not activate. I believe there was some message about it not being validated.

I tried to follow these instructions:

https://gigperformer.com/gig-performer-didnt-find-my-plugin/

(I think that article may need to be updated. It seems you no longer use the delete button. But, I am pretty sure I did what I needed to do to remove the plugin and try to scan again).

I am in the process of trying to reach the developer. Maybe it is no longer supported(?)

But, I figured I would post here in case there is something that can be done on the GP side of things.

Thanks!

Jeff

If it worked in Windows 10, there’s nothing different about GP that would make it not work under Windows 11

Perhaps your anti-virus blocked something.

Thx, I’ll look into that.

Hmm, I just took a quick look at the website for that plugin — it looks like the whole thing is based on Ruby – I don’t know if the Ruby system has to be already installed on your computer and/or since the Ruby interpreter is itself an executable, that could be getting blocked as well. Just guessing here.

I just installed it on my Win 11 machine. It scans properly and opens in GP.

2 Likes

Thanks, everyone. I bet it’s the antivirus (Windows Defender, I think). I’ll check in the am.

Update: I disabled the anti-virus. Same issue. It will not activate on the new laptop. Bummer.

Jeff

Did you completely uninstall and then reinstall the plugin after you disabled the anti-virus?

Maybe not. I’ll do that now.

Nope, no difference. (:

By the way the text in the plugin manager is: “deactivated after failing to initialize correctly”.

[Edit: Checked something else. Nope, still not working].

Jeff

By the way, there is no “uninstall” to remove this (it’s basically just a vst .dll and some presets etc.)?

So, you just delete everything? (Before reinstalling, which is basically consists of unpacking the compressed file and making sure the .dll and related folders are in the right place to be scanned. (They were)).

Jeff

Well, I saw this comment

Beware the CPU use is high, due to everything going on inside, so on less capable systems you may have to freeze the track or render it down if using multiple VSTs in your DAW

I’m not surprised if it’s based on Ruby. There are lots of decent bagpipes/uilleann pipes available from other sources that are very light weight. Maybe worth considering.

Thanks, David, appreciate you thinking about this. It’s really not much of a resources hog as far as I can tell. That was probably based on older less powerful computers. On the computer that it works on (my older one) it does not seem to hit 10% CPU. It just happens to be perfect for this song. But, right now, its not a huge deal if it only works on my old laptop, that is the one I am gigging with anyway.

You are right, there are other options to explore (I have been trying to follow your good advice to shift to less sample heavy plug ins in favor of more modeled plugins. So, this fits that).

But, yes, I have other bagpipes on my hardware and in sample libraries I own and there are other free/low cost ones around So, this is not a big deal. Actually, I wouldn’t be surprised if some of the synths I own (Pigments?) can do a similar replication.

Of course, if you think of anything else, let me know, I’ll give it a shot.

Jeff

This probably does not add anything, but, in the interest of thoroughness, when I click on it in the plugin manager, I get this message:

“Gig Performer cannot load an unvalidated plugin. Please check with the manufacturer for an updated version.”

(This appears to be the latest version. And it works on my other (older) laptop).

The original version of Windows 11 (also known as version 21H2 and codenamed “Sun Valley”) was released in October 2021.

The plugin was last updated March, 2020.

Anyway, it works on my Windows 11.

Make sure that:

  1. You are using the 64-bit version
  2. You unblocked the plugin (tick the “Unblock” check box and then hit “Apply”).
1 Like

I’ll look at that . Thanks!

Yes, I have 64 but version.

I have tried to download/install from two different sites. One site includes 3 versions 64 bit, 32 bit, and some other one).

Interestingly (or maybe not) when I scan that I think the Plugin Manager gives me the same error message for all the version.

I will look a the properties box

You should always download from the official homepage (that’s what I did).

This one? Quilcom - Flowstoners

Yes. That one.

1 Like

Maybe you and @jeffn1 can compare sha1 or sha256 hashes? I.e. 7-zip has a utility for doing that. Then you know whether you’re using the same .dll

1 Like