Sending MIDI to VST on Songpart


In the GIG setup I send Midi Program Changes to my NORD Stage just to change the sounds (Thx to Pianopaul it works fine)

Actually we arrange a new show with a lot of strings, horns and other stuff, most time with NI Kontakt.

So I use both the Nord and Gigperformer with different Rackspace for the Kontakt. In a lot of songs I have to change the „Articulation“ between Sustain, Staccato or Pizzicato s.o. live during the active playing. The same with the horns.

I do that with the Midi controller by sending the note a trigger to switch.

My trouble starts, when I return to an Rackspace, which I have used before. The VST remembers the last Articulation, which is sometimes not the correct one.

I tried to send the note by the Midi signal, withe the same technic a I send it to the NORD. The song part give me the choice. But only the Hardware Midi Outs like the Nord is visible.

I there an Option to send it automatically to the VST in the same option?

Or can I make the articulation state visible on the panel in Gigperformer ?

Thanks for Tipps and advices

You can use a Widget to send a MIDI Note to the MIDI In Plugin wired to Kontakt
And in the widget options you can define, that the value of the widget should be restored to the initial value when the rackspace is selected

Ok I will try it.

It works partly……

The Kontakt does not offers a MIDI IN so I used the keyboard MIDI IN.

When I press manually the widget, the correct notes receives the Kontakt. So it works in principal.

But it does not automatically send the note by activating the song part/rackspace

When I change the widget state in a second song part and I come Back it works.

When I change the VST via the controller the widget do not send the MIDI note

Any idea to automate it ?

I will try to send a MIDI NOTE via OSC Script

Is your controller changing the VST directly (via midi) or is it changing the widget that is connected to the VST parameter?

Sending MIDI Note with OSC

I just use the Solution of Pianopaul and send the c0 . This should be the solution

The controller is setting the VST directly via MIDI

That’s what I suspected. That won’t work!

Widgets are what remember the state of parameters so you should really never control plugins directly and instead always go through widgets