Sampletank 4

Does anybody use Sampletank 4 with Gig Performer?

1 Like

Yes - and you answered a question I submitted on it :wink: - search ‘SampleTank’

It works fine in Windows.

Are you happy with it?
How is the support in case of issues?

1 Like

I must confess that I only use it in a simple way - the problem being that I am a sucker for a new instrument and have far more than I need. I think I must be looking for the holy grail! ST4 seems to work OK and I would say that I am happy with it - although I do find the sounds a bit thin - but that may be because I have not spent the time tweaking it. For example - it may be that the the sounds sound better in a mix than stand alone (e.g. piano). I did have trouble getting the macro function working as it did not work the same as in V3 - but IK MM came back with a solution. However, the GP forum did not seem impressed with their solution.

It did take a long while for IK MM to provide the answer to the question and it was only when I went into a strop (may only be UK phrase - but meaning ‘get annoyed’) that they came back to me to appologise and said that they had asked somebody to send a reply - but it got overlooked. But in the past they have anwered questions reasonably quickly - but how good they are with really complicated ones is an unknown.

Its not cheap - so I would be really sure its what you want - maybe listen to the demos very carefully. There are some on Youtube by Jordan Rudess. But no doubt it has a lot of depth.

Thank you for that answer.

It was crashing go in windows at first release, but havent had any problems since the update of st4

I’m noticing that when I load Sampletank instances in rackspaces (ST4) that sometimes the tuning macro does not load which throws the pitch off of the multi instrument. This is obviously unworkable.

Anyone have this issue (I notice it moreso with predictive loading) and if so any suggestions?

And is it better to save the multi as a sample tank preset or as a GP preset?

I’m beginning to think that ST may not be a good live solution so hoping I’m missing something

MM

I use SampleTank4 as my piano (Alan Parsons Grand) and i never have this issue.

I am on Windows and I am running the VST3 version.

1 Like

@WITELITE ,

I’ve had a similar problem with a banjo patch before in Sampletank (just one of many reasons I no longer use Sampletank live) as in my reply to your other post. In fact, for 4 weeks it worked as expected and then one night, I jumped into ‘Save a Horse, Ride a Cowboy’ and my banjo was completely off pitch. I had to adjust quickly and pitchbend to the right spot every time I played the banjo sound from Sampletank. I tried multiple ways to resolve and eventually just had to change the pitch in Sampletank about 20 cents higher than I had to when I created the rackspace/gigfile. Weird…

X

X

1 Like

Yes, I’ve experienced this pitch problem in SampleTank 4. Less so in the global rackspace (and yes, definitely less since I’ve turned off predictive loading), but very rarely it still happens. I’m glad (not glad) I’m not going crazy doing something wrong and others can confirm it as well. There are two ways to solve this:
1: reload the instrument(s) affected
2: save the settings (when it’s working well) in the gp plugin menu as a user preset and reload this when it’s acting up.

#2 is the fastest way to get back to normal.

1 Like

Thanks guys. @ztones I’ve also noticed that by reloading the multi it will fix it but that’s not a great live solution as you don’t want to have to test your sound before you start to play the song. For some reason, the macros that ST uses don’t load which causes things like volume and pitch to be off.

Question - If I use your option 2 when it’s working, does the problem still reoccur.? It sounds like it does. I was curious as to the difference in a GP User preset and an ST multi preset?

Sounds like Kontakt may be the way to go. Bummer as I like the ST UI better.

MM

I meant to save (not reloading) the user preset when it’s working, so you have a good working copy. Then when it’s NOT working, you’d reload /open the GP saved user preset. Mine hasn’t done it since I figured this out and last did it, but I’m pretty sure that’s just coincidence.

Funny, I was thinking the same thing… Kontakt if this keeps happening.

Has anyone tried the VST2 version to see if that gets around this issue.

All though I have used ST4 VST3 daily, for a year and never experienced this, I wonder if ST4 VST3 is getting erroneous midi data that it’s interpreting as pitch change commands, a la the way OptoCompressor VST3 was getting ‘leaked midi data’ that was changing it’s input gain control erroneously. VST2 OptoComp didn’t have this same issue.

It’s just a theory.

Yes, I am using VS2 right now. To be honest, that’s by mistake, I thought it was VS3 so I’m going to try the VST3 now. Apparently you haven’t experienced it on VST3, so here is hoping…LOL

Mine was the AU version but I’ve decided to move to Kontakt. Initial Impressions are much more promising. Thanks

1 Like