Sample tank 4 crash

Anybody else here using IK Multimedia Sampletank 4? It crashes GP when I try to use it. My other IK plug-ins seem to function properly.
I’ve tried reinstalling to no avail… it just doesn’t seem to like that particular program.


There is a Sample Tank 4 update today. Maybe this will fix it.

1 Like

Yeah, I just got the e-mail notice from them too… fingers crossed.

I use Sampletank 4.1.4 VST3 in the latest version of GP with no issues.

I don’t have a lot of rackspace instances of it which seemed to cause an issue for someone on the linked thread.

Or… try rollign back to 4.1.4 and perhaps that helps.

For me, it crashes even if it’s the only plugin…

I’ve got a lot to try when I get to the studio tonight. I’ll follow up with any breakthroughs or additional weirdness

What OS are you running on and what version of GP?

Not at the studio at the moment, but it’s a brand new Mac Air M1 (not positive on the exact version number off the top of my head), and the latest GP (4.5 I think?)
I’ll verify when I get to the studio tonight.

Just to pre-answer the possible question: this is the only plug-in I have that crashes GP. Everything else I have runs perfectly.

Ok. If you’re running on an M1, are you running GP in native mode or under Rosetta?
Is the sample tank plugin Intel or Apple silicon?

(Do those match your “possible question”? :stuck_out_tongue:)

Also, can you compress and upload the crash report?

It runs natively after v 4.1.4, and I was already beyond that version when I bought GP
(IK Multimedia. Musicians First)

Currently running macOS 12.2.1

Just updated to SampleTank 4.2.2, and it’s now stable so far. (was at previous version 4.2)
Going to “load it up” and see if I can get it to repeat the issue. I’ll upload the report if it does.

1 Like

OK - w have another crash!

I used VST3 version, it was working for a bit then crashed.
Going to try the other available versions (VST & AU)

SampleTank crash report.pdf (77 KB)

Yes - as you can see it’s still crashing.

It may help IK people if you send them this so they can fix it

GP has nothing to do with the crash. Try other editions of the plug-in.

Tried VST & VST3, both crashed. Going to try the AU now. Will be sending crash reports to IK later.

Thanks for your assistance/suggestions.


This is clearly a crash in SampleTank.

Reports sent to IK this morning
Hopefully they can sort it out