Repro-5 VST3 pitch bend doesn't work in GP on Mac


#1

Hi everybody,

pitch bend doesn’t work for me with the Repro-5 vst3. With the vst2 version everything is fine.
Already contacted the GP and u-he support. Both doubt it’s a bug on their side, so the suggestion was to post this in the user forum. Don’t see any obvious mistake on my side though.

Not super critical (as the vst2 version is working). But would be nice to be future proof.

Here a video (the text is s little bit blurry, sorry should have used bigger text. First I have the vst2 plugin loaded and play some pitch bends with an MPE compatible controller (that’s why you see the pitch bends on channels > 1). Everything works.
Then I load the vst3 version. (Initially I forget to switch to the same preset. Do this a few seconds later on though in the video. Even though pitch bend settings and everything else is the same I don’t get pitch bending)

Any clue what might be wrong?


#2

Does pitchblend work with other VST3 plugins? If it does - it’s most likely not something in GP.

There is some pitch bend movement @56" and 1’04" - not sure what that is.

You controller is sending 4 MIDI messaged every time you move it.

  • Pitchwheel
  • CC74
  • CC106
  • Channel Pressure

Are you sure that some of these other CC messages is not interfering with something in the plugin?

CC74 is filter cutof normally. CC106 is undefined.

Try to send pitch wheel messages only or block the other messages using the MIDI filter and see how that works.


#3

Thanks for the hints! Have tested it with Diva VST3 (same effect, VST3 works, VST2 doesn’t. Diva is unfortunately also a u-he plugin so they might inherit the same code. Don’t have any other VST3 installed atm. but can do that).

Have filtered out all CCs and Channel Aftertouch, now I only get note on/off and pitch bend - same effect. (CC106 is used as high byte for CC74 in 14 bit midi mode. As CC74 is always the coarse part it doesn’t matter when a synth doesn’t understand this. It should just be ignored.)

Edit: Sure there should be pitch bend movement all the time. The synth just doesn’t react in vst3 mode.
Edit2: Ah you mean in the sound. This sound has two sawtooths tuned so close that they create beat frequencies - like an lfo. The pitch bend I look for is bending up and down an octave though - if it would work it would be obvious (see the example at the beginning with the vst2 plugin)

Will look for alternative VST3 plugins to test with.

Edit: Two other plugins I have installed have indeed VST3 versions (didn’t remember): Softube Modular and Pianoteq. Softube Modular instantly crashed in both VST2 and VST3 variants (have sent the crash report in).
Pianoteq behaves like Diva and Repro-5: For the VST2 versions I get pitch bends for the VST3 versions not.


#4

I’ve heard of issues with Softube (and the crashes are in the plugin, not GP) but I use Pianoteq all the time, normally the VST2 version. However, I just tried the VST3 version of Pianoteq and pitchbend is fine (although pitchbending a piano hurts my ears!)

Are you certain you’re really running the latest version of GIg Performer? There was an issue with VST3s some time ago but it was resolved/released many months ago?


#5

Not entirely sure. But at least the version number shown in the about box corresponds to what is mentioned as “latest version” on the website. It also doesn’t remind me that a new version would be available.


#6

Yep, that’s the latest - and I just tested with it. Can you try connecting a Midi Monitor plugin in parallel with your plugin so we can see the MIDI data that’s actually being sent to the plugin?


#7

We are getting somewhere. Apparently it depends on whether I filter out Aftertouch also or not. (I thought I already filtered that out in the Repro 5 experiment above. But now I retried it with Repro and in two out of two attempts it behaves exactly like with Pianoteq: With Aftertouch enabled pitchbend doesn’t work, without Aftertouch it does for both plugins). With the VST2 plugin pitch bend works no matter whether Aftertouch is on or not.

Here the behavior with Pianoteq VST3:

Edit: Retried with leaving CCs enabled (and only disable Aftertouch). The CCs don’t seem to be a problem, with just aftertouch disabled it still works. As soon as I enable Aftertouch again pitch bend immediately stops working for the VST3 version.


#8

Where are you enabling/disabling those messages? In the Midi In block or with a MIDI filter block?


#9

Sigh — I think I just found the problem — due to a typo :cry: Your mention of aftertouch/pitchbend made it easy for me to find it.
Will be fixed in next update.


#10

Great! Thanks for looking into it!
Now that Steinberg doesn’t sign commercial VST2 licenses anymore it is presumably only a matter of time until the first VST3 only plugins arive.


#11

Actually, I’m not sure what’s going on — I still can’t reproduce the problem — can you please provide me with the EXACT steps you used to disable aftertouch?


#12

Sure - you can actually see it in the video :slight_smile:
I checked the “Event blocking: Aftertouch” option in the MIDI In module. After that pitch bend immediately starts to work.


#13

Yeah, I tried that with the official 2.5.2 but everything still worked fine. If the problem was with the MidiIn block, I’d expect it to impact VST2 modules the same way.


#14

OK - I figured out what’s going on. It’s not the case that pitchbend wasn’t working - that was misleading. What was happening was that you were also generating Aftertouch messages and THOSE were getting mapped into pitchbend messages and pitchbend was getting stuck.
So I was able to reproduce that behavior in 2.5.2 and it is fixed in our latest build (not sure when that will be out unfortunately).


#15

Great! No hurry, VST2 plugins are still getting updated all over the place :slight_smile:
Was more curiousity to try the VST3 version than need atm.


#16

Well, it was a great catch – thanks for bringing it to our attention.