Report on problem and newbie question

hi everybody,
it s my first post here and i am a so far 3 day trial noob…thanks for your patience in advance…

I got myself arturias v8 bundle and the “keylab 49 mark II” for christmas (coz nobody else did).
now here is the noob question.
if i run any of the arturias instruments standalone,i get ,wich is great, the exact name of the preset (of the instrument) plus the functions of the assigned buttons and knobs on keylabs display very conveniant (no need to look on the computer screen).
if i load any of the arturias instruments into GP they work as they should BUT the display on the mark two does not get the infos coming from the plugin anymore. is there something i miss? the setup of the rackspace is basic:arturia midi in to vst plugin audio stereo out).
so far the newbie question
and here is the problem:
arturias Jup-8 V4 works perfect standalone (change presets e.t.c.) but no reaction at all if loaded into GP.

any help highly apprechiated

ps: for the devs : GP crash on closing if prompted “do you want to save the project” clicked “yes” gig saved correctly. (win 8,1)

Hi @megapeng,

welcome to the family!

I am using Jup-8 V4 with Gig Performer and it is working fine, no issue.
Can you try loading Jup-8 V4 in another DAW like Cubase or Ableton Live and see what happens?
Which version are you using VST or VST3.

Regarding Keylab, maybe special MIDI Ports are blocked by Gig Performer.
How does your options window for Midi Ports look like?

Maybe you have to use Analog-Lab as Plugin in Gig Performer and then load your instruments in Analog-Lab

hey that is quick indeed,!
still have to figure out how to upload images here…
all midis show fine

i tried it with analog lab in gig performer-no luck.

OK, I see 2 Keylab Midi Devices for Input and Output Ports.

Try to deactivate the Keylab one by one, maybe that helps.

yep there are 2 keylab devices - one is keyboard and one is DAW conrol (deactivated now).
it works now…to be honest the display is bothering me more, i d love to get rid of the screen on stage…
thank you very much!!

Fine, 1 goal reached.

What about the Jup-8 V4 issue?
Maybe you are sending on the wrong Midi Channel.

You can open the global MIDI Monitor Window and see the incoming MIDI messages

maybe a missunderstanding
jupiter works now but still no “feedback” to keylab “display” to me more important!!

Ok, did you load JUP-8 V4 within keylab in GP or did you load the single plugin?

single plugin as i tried before with keylab,midi monitor shows no out messgas on preset change,wich is the problem i guess.
give it a try with vst 2 plugin now

The MIDI Monitor does not show outgoing messages at all, only incoming messages.

Can you test Analog-Lab within a DAW like Ableton or Cubase or Reaper etc,
Maybe the display on Keylab is only working when you use the standalone version and this is a general restriction when used as VST plugins.

But that question can only be answered by Arturia support.
Did you contact them?

By the way, they know about Gig Performer

i ll try allthough i am on of the few samplitude users on this planet - i contact arturia,and let you know what samplitude does
thanks again and hhappy new year

Good luck and feel free to ask when you have question.

For you a happy new (and much better) year.

it DOES work in samplitude…

Ok, then we should ask the developers what could be done.

:rofl: That’s the way I do it too. Welcome to the GP community :partying_face:

What does exactly work in Samplitude the Jup-8 plugin or the key lab keyboard display?

returns of plugin state messages on the keylab 49 display - with does work in my main daw (samplitude) and reaper but not if the plugin is loaded in GP there is this cantabile-but only for windows and i need win and mac
b.t.w. everything else works - the post linked below refers to GP 3.6

see post her pianopaul did send me that link:

Did you deactivate all Keylab output Midi Ports?

That’s the key question. Could we see a screenshot of your Options/ MIDI input/output ports window?

Got a private message, now it is working.
As a new user he is restricted to post…

I wanted to change his status from “new user” to “basic user”, but it was already done. So, there should be no restriction. I have nothing against private messages, but it is also nice to give the solution to this issue which could be useful for other users.

Was is related to Arturia’s specific MIDI ports opened by GP?