Recording and Rogue Amoeba Soundsource

Recording in GP5 isn’t working for me on OSX. The recording window closes, creates the folder, and the recording icon doesn’t change to record mode, although it adds a zero KB file. Like it just instantly turns on and off maybe. I hear a click and pop too.

I added a rolling sampler recording plug in instead to Soundsource to record GP5 output, and noticed that added some latency kick in GP5.

So, I’m thinking something funny is going on between GP5 and Rogue Amoeba (maybe they ACE plug-in)?

Anyone using Soundsource and successfully recording in GP5? If so, any tips?


I don’t know what is soundsource , but if it can load VST plugins why not just use GP Relayer?

I am not on Mac, but this looks like a Mac permission not enabled.

The new version Loopback 2.4 does not work properly with GP5. I have had a ticket with Rogue Amoeba for 2 weeks. They really try, but there has been no solution to date. They have a new driver (ARK), it may be the problem.

1 Like

Thanks all

SirTommes - I’ll reach out to them too. Thx

If you don’t want to or can’t use GP Relayer, you could always use Blackhole

Thanks. Soundsource is like a master channel for the system. So you can do things like place headphone monitoring software over everything on the way to your audio interface, or plug ins to record a single stereo master path. It doesn’t offer the ability to record the individual underlying input and output channels within GP

There should be no reason why this shouldn’t work, apart from (as mentioned) a permissions issue. Were you a GP4 user, and had used it before?

Thanks again everyone. I added GP to my apps with permission to control the Mac and it worked!!


I was thinking of audio permission… what is that “permission to control the Mac”?

He might be thinking about third party apps that request the ability to control the Mac via the Accessibility preferences

1 Like

Bingo. That’s what fixed it.