Reason Rack not responding to GP tempo settings

Hey friends,
I’m experiencing some unusual behavior with Reason Rack. I set up a simple patch with a Drum Sequence Player and a Rytmik drum module. When I set it up, the tempo of this combo (within the plugin) followed GP’s Global tempo as expected. I set the Song to override the Global tempo at 80 bpm and it worked fine.

But once I restarted my computer and reopened GP, the plugin is now completely silo’d from GP’s tempo control, meaning it does not follow the bpm set in GP’s global tempo, nor does it follow the when the tempo override is configured in the song, part, rack or variation. Further, it is unresponsive the manual changes. I cannot get it to play at anything other than 120 bpm.Very odd.

Has anyone experienced this or know how to fix it? I do not see any tempo control settings within Reason Rack…

Maybe you have to set an option in the plugin that tempo should follow the host.

1 Like

Reason can act either as a host or a device.
Here are instructions how to configure both features:

MDrummer only copies the bpm set in GP the moment I press the ‘Play’ button of GP. Only while GP is playing MDrummer follows the changes. Maybe Reason-rack has the same issue?

Thank you for sending this @npudar, I really appreciate you doing that research.

However, I am using the Reason Rack plugin and not the Reason DAW. It allows instantiation of Reason’s instruments, players and effects inside 3rd party hosts (like ProTools). FYI, the ReWire interconnect software was discontinued years ago.

@pianopaul That is a perfectly reasonable suggestion (pun intended :wink: and I certainly have looked for some kind of setting in that vein, bit am unable to find any. Since the plugin is intended to work inside of 3rd party hosts, particularly DAWs, it make sense that there would be none. I have used it successfully in ProTools and Studio One and never had an issue. When I initially setup the Rackspace, it worked as expected.

Continuing my testing, I opened GP and initiated an empty gig. I started a new Rackspace, instantiated the plugin and configured it from scratch and it worked as expected, following GP’s global tempo change. I saved the gig, relaunched GP and then the plugin would not work at all! Nothing had been changed. I repeated the process, rebuilding the Rackspace and still the plugin would not work. ODD!

I will test the plugin in my DAWs later and see if there’s an issue with this release version.

Reporting back - I launched the Reason 12 DAW and received a message that some rack extensions were out of sync and that there was an update available. I was also required to sign in again, then sync’d the racks, installed the update.

Relaunching GP, I was able to build a new rackspace with the Reason Rack plugin and everything worked as expected. Next I opened the original song/rackspace that was giving me trouble and it was functioning as well as the day I created it.

Based on this, my guess is that Reason needed me to login again but there is doesn’t appear to be a mechanism to prompt that user to that action from withing the Rack plugin. Of course, there may have been a bug that needed to be address by the software update. In any case, following these steps resolved this curious issue for me.


Thanks so much for taking the time to report the solution.

1 Like