Radial Key Largo output

Last night I took my new gig performer computer/controller to a gig for the first time. Things could’ve been smoother. After getting setup , I first noticed that the iPad connection for sending program changes into go and receiving back page change commands wasn’t working. Turns out that my rig file that mapped everything wasn’t loaded in gp, luckily I had exported it for my laptop, and was able to import it.

I have a radial key largo attached to my pedal board which I’ve used to mix the sound between keyboards. It has 3 sets of 1/4 inputs and a USB port which can be used as a 4th input when set to live mode. During soundcheck , no audio from the computer was reaching the mixer (the Nord was working fine). I’ve always sent the main XLR outputs from the key largo to FOH. The meters in GP were registering sounds when I turned on the pink noise or played keys, it just wasn’t sent out through the XLR outputs.

The KL has two sets of outputs, the main XLR and a 1/4 out for a monitor. I didn’t have a way to test the 1/4 monitor outputs to see if they were working at the gig. I didn’t experience any issues at home and prior to leaving for the show, I was using a shorter XLR cable to connect the KL to a Scarlett on a laptop to play through each song and balance the relative sounds of the Nord and GP. Normally the KL always sends the same signal to both outputs…

Does GP separate these, I.e. does it map the XLR outputs as channel 1/2 and the monitor outputs as 3/4 somehow? I tried everything I could think of to troubleshoot the problem at the gig: unplugging the key largo, trying to switch the live mode toggle, rebooting the machine and gig performer, but nothing produced sound. GP was able to communicate with the midi ports on the KL without any issues.

I finally thought of a hack to get sound working by hooking up a 1/8 stereo line from the headphone jack on the Mac mini to the 1/8 line input on my Nord and modified GP to use the external headphone jack instead of the radial for audio. I’m going to try and recreate the situation at home today and see if I can make sense of it.

Would it be better to bring my Scarlett or Presonus audio interfaces and use either of those with GP for the audio out . I could connect the 2/4 outputs on one of those into one of the 1/4 inputs of the key largo to still send a combine signal to FOH over the XLR ports.

Had you used this interface with Gig Performer before the show?

No! Gig Performer does nothing you don’t tell it to do – if you route audio to output channel 1 (say), then that audio will only be sent to audio channel 1 of the device. That said, if your device has its own configuration settings, it may do its own routing and change stuff. I don’t know anything about the KL or its capabilities. But it wouldn’t be happening from Gig Performer.

1 Like

Did you set key largo to live mode?

This is from the user manual
The Key-Largo has two modes, set via the USB ASSIGN recessed control on the side of the unit. When this switch is disengaged the Key-Largo is set to LIVE mode. This means the USB audio from the computer is treated like any other keyboard input; you can send it to the effects loop, blend it with the other keyboard inputs, and control it with an external volume pedal. Most players will keep the Key-Largo in LIVE mode for the majority of the time

1 Like

Yes. I swapped the new midi controller into the production rig, plugged it into the key largo and spent two days playing through every song song to see how the gig performer sounds balanced with my Nord (I use both for many songs). That was working just fine the XLR output was working - sending sound to a different co user using the XLR inputs on a Scarlett.

It was in live mode. I did try toggling the switch just to be sure and then restarted gig performer in case it detected that configuration change differently during startup. That didn’t work, so I switched it back to live mode and restarted again. I will do some experimenting today and see if the 2 output channels can be addressed independently. I suspect that maybe sound was only being sent out through the monitor outs, but have no idea why, since nothing changed between my home studio and the venue.

How many output channels can you see in gig performer when key largo is used as audio out?

It looks like it sees a stereo output into the radial when it’s hooked up. I don’t know if there’s a way to change the outputs for that or say the scarlett 4i4 which has two sets of 1/4" line stereo outputs.

I finally got a chance to to some troubleshooting. I setup the same output wiring I used at the gig into a pa system and ran the L XLR into it. There was sound coming out of gig performer, but it was very low compared to the Nord.

At this particular gig, they needed me to send a single Mono XLR signal (normally I can send stereo). That seemed to drop the audio level for GP dramatically. In this mode, I was able to rebalance the sound at home by adjusting the usb gain, lowering the nord gain and raising the main gain up. But that configuration would be too loud for a stereo output.

within GP, is there an ideal way to simply switch to mono mode. Most of my hardware keyboards either do it automatically when you only plug in the L audio out cable, or the Nord has a button you can press to switch to mono output, which adjusts the audio signal.

Is there an easy way to configure GP for a mono option? i.e. adding a stereo fader/balancer right before the sound is routed to audio out, and setting the fader to pan hard left and increase the gain if needed when in mono mode, and bypassed for stereo mode? A button could by connected to the bypass setting to use as mono/stereo control?

Or would it be better to create a re-wired gig file with L+R outputs from all sources to just the Left audio out input to achieve mono mode. I’m not sure if it would be possible to dynamicly switch to that kind of wiring with a switch, so have an alternate mono gig file setup and load that instead of the main stereo version?

The goal would be to maintain the sound level and also avoid sounds that might get lost if the R channel isn’t being used.

It sounds like the usb audio is not getting to the KL input. Are you using ASIO4ALL? On the pc in the system tray, click on the icon and select the Key Largo outputs (It may be listed as XMOS USB Audio). But is The ASIO output is pointing to the pc’s audio jack or internal speakers then it won’t get to the KL.

GP will only see the two USB Input channels on the KeyLargo. Those two digital signals get changed to analog so once you get to the USB volume knob on the KL, everything else downstream can be considered as an analog mixer.


Just curious did you discover the root cause of this problem? I also have a Key Largo and I maybe have an idea of what is going on.
When you connect your KL to a Mac Mini or MacBook you can choose to use it as the main output of your mac. If you then lower the volume on your Mac that volume level will persist in the KL is my experience. So if you then select the MacBook speakers and set the volume level to a normal level, the output level on the KL remains low. To turn up the volume on the KL you first have to select the KL as the main output on my MacBook then turn up the volume of the Mac and then you have a decent output level.
I’m not sure if this intended but I also had problems like you described and I now always set the Mac volume to max when the KL is selected as the main output device.
This all has nothing to do with GP and how the volumes are set in GP. The main volume set by the MacBook on the KL is the threshold of the volume for other audio applications. So if you for instance would set the main volume to 50% then all the volumes are halved in GP even after a reboot.