Program Change from Keyboard - GP

I am currently testing the GP für live performing. The functonality is greate, it’s covering a lot of things we need; BUT I can not make work the Song change from changing a Program in my Roland RD2000.
It works if I assign the program in the RD with the respective PC number; BUT only with the Up and Down buttons with which you can switch through the program bank and NOT with the rotary knob or the quick access buttons; Example:
I assigned the “Program change: 1” and “Bank: 0” to song 1 in the GP. The program in the Roland with which I want to call up this song is on program location A17 and is saved with PC1.
Song 2 is assigned “Program change: 2” and “Bank: 0” in the GP. The corresponding program location in the RD is on D17 and is saved with PC2. If I switch from A17 to D17 using the rotary knob or a quick access button in the Roland, nothing happens. Only when I click on the Up and Down buttons from A17 (via B and C17) to D17 it switchs the song correctly in the GP. Back the same way.
So it’s not useful for me in live use, I want to freely choose my programs and thereby change the song in the GP.
GP is a great piece of software; but if I can’t do that…
I still hope that I’m just too dumb…

Could please you open the MIDI monitor in GP and check which PC is sent from your RD when the song in GP is not changed as you want? Could you then post a screenshot of the result?

Hi David,

Thanks for the Feedback.
I will drive later to our training room and will make some pics of the signals.
I had some other strange things going on as well during testing, setups in loaded Vst‘s (Triton in this case) were adjusted, but let’s see first if I can manage to choose the songs via my Piano.
Would love to use GP, but this is a “must have”

I am sure you PC stuff won’t be a big deal, GP is done for that.

I am now with the equipment.
The first pic I will upload is when I switch with the turning wheel to A17 (Bank 0, Program 1).
GP is not switching to the assigned song

The next one is when I do the switch with the up/ down bottom, coming from D17 to A17, then it switched every time as well in the GP.

Your RD-2000 is sending bank select messages (those CC 0 and CC 32 events) before the program change. Gig Performer understands bank select messages but you probably have not configured your rackspaces or songs to be using the correct banks, that’s why GP is not responding.

In the short term, you might want to tell GP to ignore bank switch commands and always use bank 0

Otherwise you’re going to have to configure your banks for each variation of each rackspace and/or songpart

Holly; with this little check at the “ignore 0” it’s working!! Thanks man. I am now limited to 128 Songs which I can address, correct?
This setting in the Rack I did already, with this I am actually choosing the Song (I hope I do right so…).

You are not limited if you configure properly not only the PC# but also the Bank# in GP.

Yes, but you can’t have it both ways. The MIDI specification only allows 128 program change values and the bank select “convention” was the workaround developed to allow multiple banks of 128 programs. So you either ignore banks or you configure all your rackspaces (technically variations within a rackspace) and/or songs (technically song parts within a song) to recognize specific banks.

The Ignore bank option was something we added to make it easier for new users to start using Gig Performer regardless of what their keyboard is sending out.

Thanks for all the help;
I am a bit confused now.
I had the The Rackspace at Bank 0 and Program 1.
In my Piano I set MSB00 LSB00 and PC 1.
This was not clean working as explained before.
After checking this “Ignore 0” it works with the PC1 (2, aso)
What should I have set instead to do it “correct”?
I gave my Songs/ Rackspaces different Programm numbers and enabled it; the Bank Setting was every time 0, so far.

I don’t understand. What does “clean working” mean?

And is that working?

I don’t know — what exactly do you want to do? If you want to use your original banks from your keyboard then you need to set the bank number in Gig Performer. Note that the bank number in Gig Performer 3 is a single number and it is equal to MSB * 128 + LSB

(A future version of GP will use separate MSB and LSB fields)

I think you misunderstand; I want to change/ select the corresponding Rackspace or Song by sending
a signal from the Song/ Programm of my Piano.
Live I do not want to touch GP/ Laptop.

Please give me an example what I would have set in the Pianosound to change in GP to a Song/ Rackspace with Bank: 1 Program: 5 for example?


If I believe your screenshot, it seems that you send a CC32 with value 32 (MSB=0 LSB=32), this leads to Bank 32 if I am not wrong.

I am not with the Piano currently; but the MSB/ LBS should be both 00, last night I tried 6 hours.
I have another Piano at home at which I could test the alternative setting.
If you could give me some examples I will try it with the MSB/ LSB settings; this will give me more possibilities in the future.

Yes, that’s what he is doing (see the red circle in the image below) but there are a bunch of other things going on here that will confuse the problem.

Note first (the GREEN rectangle) that all these messages are essentially coming one after the other (only 4 ms gap between each one) and so he is basically sending two program change messages into Gig Performer and on different channels (first in PURPLE and then second in PURPLE)

So Gig Performer is going to switch to whatever is on PC 4 and then immediately switch to whatever is on PC 3 unless you he also restricts program changes to only be recognized on a specific channel in Gig Performer

If I were you, I would just either stick to MSB/LSB being 0 or Ignore bank switching just so you can get started with GP to see if it works for you. Once you’re comfortable with it, you can enable that stuff and configure a more sophisticated setup.

1 Like

Ok, guys.
May I start without the MSB/LSB, but I am sure it had trouble as well without any number at MSB/LSB.
See the following two pics, I made this afternoon, I tried it with scenes (quick access to Song Set Up on the RD). Before I did not check this “0” ignore it was not working / switching the Songs in GP; after the help from David it did.
In any case, thanks for you great support!
Stay healthy!
Uploading: 8633D7EA-BBE4-43D0-9FFC-3CA7A1E61BB6.jpeg… Uploading: 790DB661-BB75-469B-9623-FDDA51997210.jpeg…

The pictures are not properly uploaded…