Program change confusion

#1

I admit I’m clueless on how to figure out this problem I’ve gotten myself into - I have created a number of rackspaces that contain various presets of Blue3, which I’m controlling with a Nord Electro that is in Setlist mode. I’ve been successful in being able to switch to different programs on the Electro that select the rackspaces in GP. However, the issue I’m having is when I switch to a preset on the Electro that isn’t sending a program change to GP, the Electro is triggering the last rackspace that I specifically set up with another Setlist program. In other words, if a particular Setlist slot has an electric piano, it’s triggering an organ rackspace in GP. At this point, I don’t have a clue as to how to address this issue, as obviously it’s going to be an ongoing problem for me. Where do I even begin?

#2

What does the Global Monitor Window show as incoming Midi events?

#3

I’m not sure I understand. If your electro does not send the program change, why would you expect Gig Performer to do anything other than just respond on whatever is the current rackspace or song part?

#4

The Electro is sending program changes and GP is responding to them. I have 3 presets in the Electro that GP is correctly responding to the program changes sent from the Electro. I must preface this by saying that the presets in the Electro are stored with the gain knob turned all the way down so there is no audio output from the Electro, as I only want to have audio output from GP. My struggle is with presets that do require Electro audio output. Since I have no rackspaces programmed to receive any additional program changes other than the ones already present, the last rackspace that was called up remains and consequently still responds to MIDI notes.
How do I begin to address this?

#5

Sorry if my initial post wasn’t clear and concise. GP is responding to any and all MIDI information I send to it from the Electro. I guess what I’m trying to communicate is that is how do I set up GP so that it doesn’t respond to every program change the Electro sends out. MIDI program send/receive in the Electro is only globally on/off.

#6

If there is nothing attached to a particular program change message - nothing will happen so if you want an unused PC message to go to say a plugin - just make sure you don’t have a rackspace variation or a song part respond to it and that you’d not assign some other function to that particular message.

You have some global control over PC message distribution under global MIDI options as well.

#7

Sorry if I’m having difficulty explaining more clearly what my problem is. Under Global MIDI in my Electro, my options for Program change are Send,Receive and Send/Receive and Off. For performance, I utilize Setlist mode which is basically 4 banks of 50 program slots. Using MIDI Monitor, I see that when I move from one Setlist slot to another, the Electro is sending out, among a few other CC’s, Bank Select 0 , Bank Select (fine)0, followed by the program slot #: 1,2,3,etc. I have 3 slots in Setlist 1 - 24,25,&26 that are sending these particular program changes (24,25,26) to GP, where I have 3 rackspaces set to respond to 24,25,&26. Moving between these 3 programs on the Electro switches to the 3 rackspaces in GP with no issue. However, it’s when I say, switch to program # 27 on my Electro that my initial question arises - In doing so, the last rackspace that was selected from the Electro remains selected and consequently, the rackspace and whatever program I have called up now on the Electro are now playing simultaneously. Without knowing any better, at this moment, I see my only option as being that the need to create multiple rackspaces in GP that contain no plugins, so when I subsequently switch to a program on my Electro the program change will simply call up a silent rackspace.
Due to my relative inexperience with GP, I’m sure there is a more elegant work around to this issue. I’m guessing that it involves the use of the MIDI in plugins?
Thanks for any and all advice and support!

#8

If your Electro is sending out bank selects then you need to make sure that you have configured the correct bank selects for the rackspace variation as well.

#9

Also, you may want to turn LOCAL OFF on your Electro and use GP rackspaces to receive input from your keyboard as well as send it back

#10

Thanks for all your responses! Unfortunately, Electro MIDI implementation is pretty basic - Local on/off Global MIDI channel, CC Send & Receive on/off individually or both on/off & Send/Receive. Ditto for Program Change & MIDI Transpose at In/Out. Also, due to the organ mode, Upper, Lower and Split mode channel setting capability.
So how exactly would turning Local off address my issue of only having specific Electro program changes interface with my GP rack spaces? Does the MIDI module have the ability to filter out specific program change #'s, or is it simply program change on/off, or bump MIDI channels? Currently, I’m using about 15-20 programs in Setlist mode on the Electro. I’m still not clear if I need to set up 15-20 rack spaces that have no widgets or modules so I’m only hearing the audio output of the Electro.
Am I even on the right track to solve my dilemma?

#11

I think you have hit on the best solution… set up an empty rack space in GP for any programs in set list mode on your Electro that you don’t want anything playing in GP. That’s pretty easily accomplished, just “add rackspace” and assign the PC # for the setlist program you only want audio from Electro.

I don’t know the Electro but on my main board, the equivalent of your set list programs would allow me to set the MIDI out channel for each specific program, so I could set that to a channel that GP is not receiving on for those programs I did not want it to respond to. But it sounds like you say there is only a global channel you can set on the Electro.

1 Like
#12

Thanks to LilyM and dhj yesterday, the solution was, as they say, hidden in plain sight. Whenever, I want to play a preset on my electro that I don’t want to control a rackspace in GP, I have simply created a rack space that has nothing in it and assign it a Program change that coincides with the preset on my Electro. I then have put my Electro presets in an order that will then allow me to either control rackspaces in GP or not depending on my particular needs for that song.
Thanks again for everyone’s advice and for scratching your heads in an attempt to decipher what I was actually trying to do:).
I promise that all future posts my me (and there will be many, many more) will be much easier to comprehend.
Mark