Problem with Midi Connection Aliases

I have 2 rigs I use with Gig Performer (3 if I include my backup live PC as constituting an extra rig). I have created a Midi Connection Alias for 2 keyboards and a set of Pads named “TOP-kbd”, “BOTTOM_kbd” and “NanoPad2”. I created a gig patch on my studio PC where “TOP-kbd” is connected to an Arturia Keystep 37, “BOTTOM_kbd” to a NI Kontrol S61 MkII and “NanoPad2” to a Korg NanoPad2. Everything operates as expected.

On my Live PC, “TOP-kbd” is connected to a Nektar LX88+, “BOTTOM_kbd” to a StudioLogic SL-88 Studio and “NanoPad2” to the same Korg NanoPad2. When I load the gig patch, none of the aliased MIDI connections pass MIDI to the VST instruments, even though the Rig Manager connection entries flash green when I tap each keyboard. I tried using the “Apply” button but still no MIDI passed to the instruments.

Is there some specific order these steps have to be performed in or is there some function or setting somewhere I haven’t set correctly to make the aliases work between different rigs? I am running GP4 v4.0.51 on Win10 64bit PCs.

Are you using an USB hub?
on Windows the device names can change when you plugins your Audio Interface on a different physical input.

Can you upload your Rig Manager file and upload a small gig showing the issue?

Thanks fore the response, Paul. I created an example which suddenly seemed to start working. With my developer’s hat on, the only applicable difference I could see was that the bottom keyboard alias was called “BOTTOM_kbd” and I changed it to “BOTTOM-kbd” whereupon it started working.

I did wonder if underscore characters need any special handling in XML (XML being the format of the .gig and .gigsetup files) but I’m not aware of any such restriction, so maybe there is something in the GP4 code that is working differently if an alias name contains an underscore? Maybe something for you guys to investigate when there is a spare moment but, for now, my own specific issue is solved (or at least circumvented).


Uhm, not sure about any special handling but if you referred to it with ‘-’ in the rig manager but with a ‘_’ in the block, those would be seen as two separate names.

I had the Alias named with an underscore and then chose the correct physical connection to assign to it in the Rig Manager. I let the Midi In block take the default name assigned to it.

I’ll try and do a test to see if I can recreate the issue I had previously and, if I can reproduce it, will post a test file or confirm I couldn’t recreate it if not.

Many thanks!