Problem creating new Song

Hi guys,
I am having problems with GP when trying to create a new song the software freeze for approx. 10 minutes :thinking:…all I can do is to “kill” the process. Has anyone had any similar issues??
I have tried the " repair" function of the software without any luck.

Are you running out of memory? :thinking:

Absolutely not. I have 64GB of RAM installed.

Does this happen when you create a new blank gig file?

Alternatively, check if you have MIDI loops.
Do you use scripts?

Yes, I have also tried with a blank gig file…same issue. No scripts and no loops.
I use however the audio file player for backing tracks but as it also happens with a completely empty gig file it must be software related.

Do you use any virtual MIDI devices?
What happens when you disable all MIDI devices?

So the wait appears after you enter the song name and press the OK button?

You’re not using network shares (maybe without knowing)? If a share is not available Windows might take its time (although 10(!) minutes is really long)

Hi again all of you,
Thanks for all the feedback. I found the issue. I had the OSC turned on…when I switched it off everything startet working again :ok_hand::+1:

You won’t believe it, but after @npudar mentioned the MIDI loop, I thought of the OSC loop. But I kept it to myself, because as the police investigators say: “when you hear hoofbeats, think horse, don’t think zebra”.

This time “zebra” was the right guess and it was not a MIDI loop but a kind OSC loop: is your local host and thus equivalent to and you used the same port 54344 for both the remote client and the GP listening port. Which means that with OSC active you send and received OSC message on your local GP computer, which makes an OSC loop.


Hmm, the problem was not just that OSC was turned on but rather that it had been explicitly configured to use the same port and host for both sending and listening thereby causing the feedback loop that @David-san predicted. What was the reason for that configuration?

No reason - I should not use that with my current setup.

Well, that configuration must not be used at all, ever — and we really appreciate your reporting that this was what went wrong.

We’ll have to add some checking for the next version to make sure that users don’t end up creating a feedback configuration by mistake.


I am really glad that it was just me creating the problem (sorry😉) I dont need the OSC so I also can’t explain why it wsa turned on.

Don’t be sorry, it was an interesting issue and we will put some more checking in the next version.

But it wasn’t just that OSC was turned on. It was because the ports were the same. That is something you must have set explicitly and we need to protect against that.

1 Like