Plugins Crash 10x in a row then stop?

Using Gig Performer demo/trial haven’t purchased yet. Seems to work fine with many of my plugins but a few crash it including BreakTweaker.

Is there a way I can report logs to the gig performer folks? Anyone else have Izotope BreakTweaker and it works for them?

Windows 11,
gig performer 3.8.1
Izotope Break Tweaker (a groovebox)
Arturia vcollection

Many vsts crash 8 or 10 times in a row, and then, somehow something changes and they stop.

Is Gig Performer recording each crash and trying different stuff each time?

Why is the experience of testing out GP so flaky?
Has VST3 and VST2 versions. both crash GP and work find in all other daws I own.

Gig Performer is at version 4.15

Weird. I downloaded yesterday from the main plugin alliance website.

That is weird – you’ll have to contact PA for that issue.

Yea no need, re-downloaded from the main gigperformer website.

I don’t get why there are two places to download this from.

I just googled gig performer and got the PA one I guess.

THe V4 Gig Performer is a much better version

Welcome @warpCanada !

PA is a partner/reseller and have a special version that only runs PA plugins (but also an Unlocked version that can run any plugins). Both use PA licensing.

If you’re not already in the PA ecosystem then you may as well get it directly from the Gig Performer site.

It sure is! :grin:


GP has matured greatly over the years in relation to plugin compatibility. At this point, most of the crashing issues are the plugins crashing and bringing down GP. Sadly, a lot of plugin vendors will only test their plugins with major DAWs, and will consider them’ working’ as long as they work in these.

But I’ve witnessed many occasions where the GP devs will do their best to reach out to plugin devs when there is a GP user experiencing plugin crashes - as GP can’t solve the problem of the plugin itself crashing.

I haven’t heard anyone mention that Izotope plugin before. If it’s a critical plugin for you, then you can obtain the crash reports and Windows users here or the GP devs can help confirm it’s the plugin crashing and you can forward that information to Izotope.

Hi @warpCanada, welcome to the GP community forum :wink:

This is mostly because DAWs usually don’t require plugins to fully implement the VST/VST3/AU standards as they don’t need/use everything that plugins are supposed to implement. GP suppose that plugins fully follow the standards and fully interacts with them, which can cause plugins to crash (and crashes GP) when they are not correctly implemented. The crash report can be posted here to be analyzed if you want.

1 Like

Hi - I am having the same issue. I moved to a new laptop (from windows 10 with GP 4.7 to windows 11 with GP 4.8). Old laptop GP+Break Tweaker works fine. New laoptop GP+Break Tweaker = Crash.

But Break Tweaker works fine in Reaper on the new laptop. I have had the reply from GP support saying “other software is not as rigorous as GP with respect to the VST standards”. But this seems odd when iZotope Break Tweaker and GP worked on my old laptop.

I wonder where you ended up with this issue - is it resolved for you?

When you create a new gig with 4.8.2 and load break tweaker, is it crashing also?

Yes. I am really struggling with this issue. I am quite techy so not afraid to try things. I think that in my old setup the iZotope was a VST2 not 3. I think tis may be the root of th issue. I am now seeking how to get the vst2 installed.

I just tried to load Break Tweaker VST3 and it crashed.

In the crash report this line appears:

PluginHooksVST 0x10a861adb 0x10a82f000 + 207579

I think this VST3 version is somehow a dirty hack.


Yes - I think you’re right.

I think I have (kind of) fixed it.

I copied the old VST2 dlls ifrom my old computer nto the programs/vstplugins folder on my new computer so that GP picked up both the VST2 and VST3 versions.
I disabled the VST3 version in the GP plugins window. Now I can choose and use the iZotope Breaktweaker (VST2 version).

The iZotope VST2 dll can’t see and use the libraires of sounds and presets it needs - but I will fix that somehow.
The basic problem is at least now fixed.

As a user I have to express a little furstration (and I actuallty work in software integration in the medical information field). When two companies say “it’s the other guy” when facing integrations it effectivly pushes the problem back onto the user to solve (as I have partly done).
My view is that if two comanies claim to be experts in an interface (GP and iZotope/NI; both well known big names) then these two companies should work together to solve the problem.

Thank you for responding on this thread.

I saw your support ticket. Your crash log clearly says that iZotope is the culprit.

And similarly to Shakira’s “Hips don’t lie” → in the VST host world “Logs don’t lie”.

And iZotope people seem to ignore to aknowledge that they don’t know to build VST3 plugins. VST will most likely work, but VST3 are buggy…

And that lasts for a very, very long time! See here:


Thank you. If those guys ever wanted to cooperate, we would gladly give them an NFR license for Gig Performer (like we do for many plugin developers and also have NFR licenses for their plugins) and also do some testing on our part.

I recommend that people create support tickets to iZotope – at one point (when the critical mass is reached) they must start fixing stuff.

1 Like