Output Arcade Input Quantize sync issue in GP


#1

I’ve been playing with Arcade quite a bit lately, but I can’t seem to figure out how to sync it to GP tempo. I selected Input Quantize in Arcade, but when I start GP play/click, Arcade does not sync to GP click. Rather, Arcade starts making sound immediately when I press keys on my controller. Curious if there is anything I should try on my end to resolve? I confirmed that Input Quantize does work correctly with my DAW


#2

Ah … for that to work you have to press the “Play” button in GP so the plugin has a reference point for the beat.


#3

Unfortunately, pressing Play still does not cause it to sync to GP’s tempo. I should have mentioned that originally. Any other ideas?


#4

I tried this with GP 2.6 and GP 3.0 and it worked in both cases. Try setting the tempo lower. Say 40BPM so you can better gauge the situation and switch the metronome on.
Start the Play so that the play button is green. Now if you press a key just after a metronome click and hold it - the sound should not be played instantly, but rather it will be played on the next beat (if you use 1/4 in the Arcade).


#5

That is what I tried, but I will keep experimenting. I’m using Windows, so maybe that is a factor.


#6

I tried again, and still no luck syncing. I set GP tempo to 20 bpm, selected Arcade’s input quantize of 1/4, pressed play button in GP to hear click, started pressing arcade keys… audio always starts immediately when I press Arcade key. Tried many many times. :frowning:


#7

The only thing left to do is possibly attempt to reproduce on Windows as this works as expected on OSX.


#8

Gave me an idea… Turns out this issue was specific to VST3, but works correctly for VST2. So I switched to VST2 for now. Thanks! Not sure how to mark this thread as Resolved.


#9

Well, it’s not really resolved — it’s great that it works as VST2 but we still need to understand why it’s not working as a VST3