OSC problem on a specific router (Waves WRC-1)

Have you ever had a problem with OSC on a specific router but not any others? My iPad (Lemur) refused to talk to Gig Performer last night, even though the OSC settings were correct (triple checked). Communication with our XR18 router was fine. I am stumped. I see nothing in the advanced settings of the router that would block the protocol.

I tried the the “Broadcast” IP address trick, but that only worked about half, and that’s an overestimation - with only a few elements showing up in Lemur when I change songs manually and Lemur has absolutely no effect on GP controls.

Any pointers? Everything works fine on other routers. This ONLY happens on our gig router (Waves WRC-1) and I’d really like to use Lemur/OSC with GP. Thanks in advance!


It could be that you have it specifically open on this router the ports you want to use for the OSC communication.

This router perhaps has the “basic firmware”.
Note that there is also an “advanced firmware”. Link: WRC-1 V2 WiFi Stage Router | Hardware | Waves

I suggest you to install the most recent advanced firmware and to try to configure your router afterward.

I do have the advanced firmware installed. Unfortunately, I don’t see anywhere to open/block specific ports. Port forwarding is available, but that doesn’t really apply. :frowning:

Perhaps to ask Waves support about WRC-1 and OSC?
I couldn’t find any info on Google regarding WRC-1 and OSC (I also used: UDP, iPAD, TouchOSC, Lemur and other keywords in my queries).

Like no one used it for OSC :thinking:

Yes, this definitely isn’t a GP problem, but I was hoping to get lucky. The Waves community doesn’t allow troubleshooting posts. I sent their support a message. Now, we wait.

Seriously, there is very little available info on this router. Crazy.

Turns out there was an “Isolated Client” setting buried in the advanced wifi settings for each SSID that was enabled by default to prevent wireless devices from communicating with one another. I disabled it and everything now works as it should.


Thank you for your feedback! :slight_smile: