New version 4.7 has crashed several times

Hi all, this evening I used 4.7 version for the first time during a music session but I experienced some chrashes.
Two times during menu navigation (general menu, rack preloading) and once closing the software (runtime error).

Both under windows. No issues with previous version of GP. Same rackspace.

Do you have experienced something similar?

I experienced a crash while trying to load a project (shared crashlog with developers) + one hang on Mac so far while working on markers in new Streaming Player.

So let’s see what crashed.

Please follow this instruction: LINK

@npudar I’ll check next time an error will occur (I hope never :smile: ) Is there a way to get an error log for past events on not?

If it is in the rackspace loading phase, then it is most likely that a plugin crashed.
Just make sure to save the log, because it will give the insights :slight_smile:

You can have a look here: AppData\Local\GPErrorHandler\UnsentCrashReports

Do you have any GPScript running?

Did you try to shut down the computer after you closed GP?

FWIW (not sure relevant) I would always get an error message when I tried to shut down my computer after using GP if I did not wait a few minutes for ram to unload from the program. So, now I keep my eye on the Task Manager and wait until GP is not longer listed on top (sorry if not relevant).

1 Like

Fresh crash from seconds ago: happened while trying to switch to another song.

Translated Report (Full Report Below)

Process: GigPerformer4 [23278]
Path: /Applications/
Identifier: com.deskew.gigperformer4
Version: 4.7 (4.7)
Code Type: ARM-64 (Native)
Parent Process: launchd [1]
User ID: 501

Date/Time: 2023-08-31 17:59:31.1374 -0700
OS Version: macOS 13.5 (22G74)
Report Version: 12

Crashed Thread: 0 HotFudge Dispatch queue:

Exception Codes: KERN_INVALID_ADDRESS at 0x0000a637a439cfd8 → 0x00002637a439cfd8 (possible pointer authentication failure)
Exception Codes: 0x0000000000000001, 0x0000a637a439cfd8

Termination Reason: Namespace SIGNAL, Code 11 Segmentation fault: 11
Terminating Process: exc handler [23278]

VM Region Info: 0x2637a439cfd8 is not in any region. Bytes after previous region: 41539383971801 Bytes before following region: 63532695957544
commpage (reserved) 1000000000-7000000000 [384.0G] —/— SM=NUL …(unallocated)
—> GAP OF 0x5f9000000000 BYTES
MALLOC_NANO 600000000000-600008000000 [128.0M] rw-/rwx SM=PRV

Thread 0 Crashed:: HotFudge Dispatch queue:
0 GigPerformer4 0x1014a7398 0x100cb4000 + 8336280
1 GigPerformer4 0x10112e454 0x100cb4000 + 4695124
2 GigPerformer4 0x100e4aea0 0x100cb4000 + 1666720
3 GigPerformer4 0x100e4b058 0x100cb4000 + 1667160
4 GigPerformer4 0x100e4ace0 0x100cb4000 + 1666272
5 GigPerformer4 0x10112e000 0x100cb4000 + 4694016
6 GigPerformer4 0x1014aa388 0x100cb4000 + 8348552
7 GigPerformer4 0x1014e2d20 0x100cb4000 + 8580384
8 GigPerformer4 0x1014ead24 0x100cb4000 + 8613156
9 GigPerformer4 0x1014e5a50 0x100cb4000 + 8591952
10 AppKit 0x18c075ef0 -[NSWindow(NSEventRouting) _handleMouseDownEvent:isDelayedEvent:] + 3476
11 AppKit 0x18c000b2c -[NSWindow(NSEventRouting) _reallySendEvent:isDelayedEvent:] + 364
12 AppKit 0x18c0007ec -[NSWindow(NSEventRouting) sendEvent:] + 284
13 AppKit 0x18bfffb30 -[NSApplication(NSEvent) sendEvent:] + 1556
14 AppKit 0x18c24fc48 -[NSApplication _handleEvent:] + 60
15 AppKit 0x18bec6fa0 -[NSApplication run] + 500
16 GigPerformer4 0x101297ddc 0x100cb4000 + 6176220
17 dyld 0x188877f28 start + 2236

Thanks. Will take a look at this in the morning. Can you say what you were doing when the crass happened?

The problem is I can’t pin point it to anything in particular. Before our rehearsal I was showing my friend new markers I entered in SAFP (all 60 of them), so SAFP plugin was opened on one screen (laptop). Main GP window was on different display, connected via HDMI. I just switched to a different song without editing anything or making any changes to the project.

Yes once happened. Yesterday i tried to replicate the issue without success.

Next time, please, upload and post only the .zip file. :wink:

OK — this crash report was tremendously helpful - seems to be an issue updating the number of actions in a marker

Question: Do you have a streaming file player in individual rackspaces or do you have just a single one in the global racksapce?

1 Like

Single instance in global rackspace.

1 Like


1 Like

I’ve installed 4.7 on my MacBook Pro Intel 16 GB RAM Ventura OS. It has crashed several times while I am editing something. Is this happening to others will similar systems to mine? Should I be sending in the crash reports to Deskew and/or Apple? The next time it does, I will read the error closely and note what I was doing just prior.

Please post the crash report here

Are working with the Streaming Audio File.Player?

By any chance were you deleting a marker while an audio file was playing or any other way that actions for the marker you were deleting could have been triggered?