Native UAD Plugins values not saved

Trial testing GP4…

  1. created a simple Rackspace using a VST3 UAD plugin and Soundtoys plugin
  2. changed some settings directly on both plugins
  3. save and exit the program
  4. upon restart only the Soundtoys plugin values are retained.

This happened for all UAD plugins I tried. As a workaround, I can link UAD parameters to widgets… they retain but is impractical since this is a channel strip plugin with 30 or so tweaks that I never intend to change outside setting initial values.

Any ideas? Seem like a bug somewhere… possibly UAD.

Can you try with a DAW like Logic or Cubase or Reaper or … ?

Good idea.

Tried Cubase 12, and it works just fine. Create Project, insert UAD Plugin, change something, save, close, open again… settings are retained.

Doesn’t seem like a UAD problem.

Tried one more thing in GP4.

Tried creating a ‘preset’ in the UAD plugin with the changed values.

GP4 saves the preset name but not the values.

That is very strange.
Does that happen with each UAD plugin?

What version of GP4? Mac or Windows? What OS?

We’ve lots of UAD users - this is the first I’m hearing of an issue with saving state. Are you sure the state is not being saved/reloaded? The preset NAME might not get set but as long as the plugin obeys the normal mechanisms for recalling/storing state back to the host, it should work fine.

Sound City Studios reverb resets everytime i change Rackspace or close and open Gig Perfomer

Sounds like those plugins are not properly handling providing their state to GP (through the standard API) or restoring their state when it’s sent to them by GP.

Have you reported this issue to UAD?

I also have this plugin and it doesn’t work for me.

Simplest steps… Create new blank project… drop in Sound City Studios… change anything, save, close, reopen… resets to default settings. Are you sure this works for you?? I am using VST3 UAD Native plugins.


No… because it works in Cubase 12 and VST Live latest edition. I have an older version of Cantabile… I could try that too.

I have a pretty good feeling UAD is going to say ‘No it’s not our problem’

I believe it also works fine in the new Nembrini VST host (Nexus), so it seems to be some combination of Gig Performer and this plugin.

Very strange but we will look into it ASAP.

Ok, thank you. That would be helpful.

We have been able to reproduce this issue and we’re testing a fix for it now.

Thanks for bringing this to our attention.


1 Like

We was just evaluating GP4 and this kind of active involvement in your product means a lot. I just purchased the full version. Thank you. Appreciated.


The UAD issue has been resolved and will be handled properly in the next release.

1 Like