MIDI in not working

I’ve been using GP for several years now and I’m having a problem that I’ve never encountered. I’ve been away from my keys for a few weeks and now MIDI In is not working with one of my keyboards.

I have PC88 sending MIDI through a Focusrite 2i4. The Focusrite shows midi activity and GP shows MIDI activity when I play the PC88. However, when I insert a MIDI in block, I get no activity in the MIDI in block. It doesn’t matter if I use an OMNI in or a FOCUSRITE in…I get nothing in the MIDI in block.

I can play on my other two keyboards and I get activity in the MIDI in block if using the OMNI in, but nothing from the PC88.

I’m probably missing something obvious, but this is an issue in a brand new gig file or in several old files that worked previously, and I’ve not experienced this before.

I’ve checked the MIDI ports and they are activated. I’ve checked the Rig Manager to make sure that the MIDI devices are associated properly. I’ve also removed and inserted MIDI blocks. I’m stumped.

I just got the latest update to GP4 and still no MIDI activity.

If anyone can help point me in the right direction, it would be greatly appreciated.


Can we see a minimalist gig file that you are using. Maybe just with your PC88 through Focusrite.

Maybe also some screen shots of your Rig Manager and MIDI ports


Please open your global MIDI window and confirm that the keyboard in question is in fact generating the expected MIDI messages.

In this case it could be an hardware issue.

1 Like

Or you could have a gig script blocking the input in your gig file which is why I was looking for a copy of a gig file that exhibits the problem.


1 Like

I think when no message is shown in the global MIDI window, then it is a hardware issue.


I think if you have a callback that blocks the event and you don’t inject MIDI back into the source, it will not show up on the Global MIDI Monitor but I may be wrong.


Another possibility is another application that took control of the incoming MIDI port before Gig Performer started (if on WIndows).


Did a quick check of the Global MIDI Monitor this morning and it shows activity when I play the keyboard, but still nothing to the midi in block.

I’ll try to do some more troubleshooting this evening and provide screenshots and a gig file.

Thanks for all the help.

If you use Rig Manager, please check that the Midi in Device name didn’t change (not rare with Windows).

MIDI In block must be assigned to another MIDI Input device.

Yes, that’s the only possibility. Does it work if you use a MIDI In Omni block?

1 Like


@sas, could you please start form scratch, i.e. from a new gig file? In the default rackspace put a GP MIDI monitor and connect it at the output of the MIDI in OMNI block. Open both the Global MIDI Monitor and the MIDI Monitor connected to the MIDI in OMNI. Play a few notes on you controller, and act on other buttons or knobs. Do you still have something in the Global MIDI Monitor window and nothing in the MIDI Monitor?
Could you please make a screenshot of the full list of your MIDI ports and another one from you Rig Manager config? (I could reproduce something like your issue by misconfiguring something in Rig Manager)

I started from scratch…new rackspace, new omni in, etc…Still seeing midi information in the global, but not in the midi monitor attached to the midi in block.

At work today, I came across a USB Device Tree Viewer app. I downloaded it and was looking at the various USB ports. I unplugged my usb hub, computer didn’t like that and shut down. upon restart, I recreated from scratch the very simple rackspace I had lost on the shut down but… had no midi into my 2i4 and no midi in to GP4. very strange…So, I opened up the USB device tree viewer again and when I did, all my usb devices showed up and midi in started working.

I can only conclude that there was some USB issue that unplugging the 2i4 and replugging it resolved.

I certainly appreciate everyone’s input. It was helpful.

If the issue arises again, I’m sure to be back.

Again, thank you all for weighing in. This community and GP staff are awesome!