MIDI from local rackspace to global stopped working

Hello,
MIDI from my local Rackspace to Global suddenly stopped working. I’ve not changed anything in my settings or in my gig file. Before starting Gig Performer, there was a warning about an error when listening to OSC (see attachment). I tried the netstat command, but I haven’t found any other application that listens to 54344, windows firewall disabled.

Several possibilities

  1. Did you previously have GP open and closed it but didn’t wait for it to completely terminate before opening it again?
  2. Did you change anything outside of GP such as an OS update that might impact your firewall and prevent GP from accessing a port without permission?
  1. No, GP closed ok.
  2. OS did update, but firewall is turned off.

Tried the same file on my laptop and it works fine, so it’s a computer issue. Now I’m going to update my laptop to see if I can recreate the issue.

Made the same update on my laptop and it works just fine. Going to check other apps on my PC.

Perhaps you could use NMAP on your PC to have a better idea regarding what’s happening to your ports?

I usually get this warning when I activate GP (I deactivate GP before any serious update to OS or driver)

  1. Nmap says the port is closed.
  2. Tried deactivating and activating GP and no luck.
    :thinking:

I think GP itself somehow tries to start listening twice. The moment the message appears, the listening port is already closed, so no trace of the culprit is left. A next time I’ll use procmon to see if GP is indeed trying to start listening twice.

Tried reinstalling GP and no change. I downloaded Process Monitor, but it’s beyond my capabilities. I don’t even know where to start looking… :man_shrugging:

This has happened to me a few times when Windows did a mandatory update.

It disabled OSC on its own.

Since I figured it out, whenever it does an update, I always check a rackspace that uses OSC (Global rackspaces). If it is not working, all I now do is re-enable OSC (toward the top, under the General tab). In my case, that has always worked:

Let us know if that works (this is a pretty “simple” solution, so maybe you have a more nuanced issue than this).

1 Like

Now it works. I ended up changing the port number to a 4 digit number (9002 - default in new instances of GP?) instead of the 5 digit one I tried yesterday (from 54344 to 55115), which didn’t work. I hope it stays that way.

Thanks for the feedback. I never use such big port number, but as far as I know the max port value is 65535, so I don’t understand. :thinking:

1 Like

Apparently there is a “Port”, a “remote client port”, a “Gig Performer Listening Port”…

I never learned this as much as I should have. I just use OSC to use the Global Rackspace.

I just followed this Blog and read through some posts in the forum:

A few things that did confuse me at some points is the need to to have different OSC addresses if you are using more than one instrument in the Global Rackspace and the different places to put the OSC handle. So, I asked some questions on this forum and David (dhj) and others helped me out.

Do you also use large UDP ports like 54344?

Nope, usually 9001, 4xxx and alike. I’ve checked whether these ports are in use or not. As I’m a network engineer in daily life I’ve been there before :grinning:

So, for the moment, it is difficult to conclude anything from what we know. :thinking:

Indeed

Tried this, but sadly procmon doesn’t trace udp ports starting to listen. Neither does wireshark, but that only monitors traffic, so that is no big surprise.

But after some experiments I think it only happens when you have multiple network interfaces enabled. There’s a good chance you have that: for example a wired ethernet interface and a wifi interface.