MIDI filter to block CC#11 (Expression)

I’m trying to block volume pedal in Pianoteq in a new variation but it doesn’t work. I’ve made a switch on the panel (red led) with the bypass function, mapped it with a plugin (midi filter) parameter CC#11 (Expression).

Midi monitor is showing me that the switch and midi filter are working (expression pedal down --> no data; expression pedal up --> CC data OK), but Pianoteq just doesn’t mute when my expression pedal is down.

What am I missing?

I think we need a bit more information.
From your screenshots - it looks like the button widget is connected to the parameter CC #11 in your MIDI Filter.

When that button is down (on) the CC#11 will be blocked. If you switch it off (up) the CC#11 will pass through.

Is that what you want or is there some other behaviour I am missing?

That’s exactly what I want - to have a variation, where my volume (expression) pedal will be disabled for my piano (it’s for a song Whiter shade of pale, where in first part of a song it’ just a singer and a piano - then when band join in, I just flip up volume pedal and add hammond sound to a piano layer).

Take a look at the attached gig.
I like it when widgets to bypass or block something are inverted.
In this gig when the widget is activated expression is not blocked, when it is deactivated it is blocked.
But this is just a matter of taste - I like to allow something more then prohibit something.

Expression.gig (9.6 KB)

Pianopaul, thank you for your gig file. I understand the logic, but I’m more of a ‘red light’ guy myself… :smile:

I have managed to solve my problem with reloading (replacing) Painoteq VST in my rackspace. Then everything started working as it should from the beginnig. I don’t know whether it was GP or Pianoteq, I can’t recreate this behavior.

Ok so you think “pessimistic”, I am more “optimistic” :wink: