Melda and Waves Plugins crash GP

I’ve been traveling the past couple of months, back home and trying to start using GP again but having problems, namely, that whenever I try to add a VST3 from Melda or Waves into a rackspace, or open a plugin from Melda or Waves in an existing rackspace, GP crashes. I reinstalled all my Melda and Waves plugins/libraries and did the “repair” GP option but it does the same thing. GP generates a crash report which is attached. I was wondering if one of the community or developers (@dhj )has encountered this and any recommendation to resolve??? Thanks!

PS - I have numerous other plugins - NI, BlueCat, IKMM - to many to mention, and they all work fine load and work fine as far as I can tell. It’s just Melda and Waves!!??

I am using the latest version of GP - 4.7.

CruiseC Crash (34.2 KB)

What version of GP are you using?

First i would try to use the “normal” VST2 instead of VST3…

Hi Eric, all were working before and I was using them for since GPV3 so I know they work including on GP4.7, but something has changed, and it seems to affect only them. I;m wondering if its my graphics card. I changed from my NVidia graphics card to the onboard Iris graphics and reset the BAR. Maybe I’ll try reinitializing that.

Which Melda plugins do we talk about specifically?

This process crashed:


Do you use the OpenGL renderer in Gig Performer?

1 Like

Hi Nemanja,

Just figured it out. I have been thinking about building a new mini SBC, mini-ITX or micro-ATX computer and imbedding that on my equipment rack. I built my current mini-ITX as gaming capable with a top of the line (for it’s time) graphics card so I wanted to see how well the onboard IRIS chipset would perform.

In any case, I set the BAR back to normal which disables the Compatibility Support Module, that had no effect, so then reinstalled my graphics card and everything works again.

So that is the good news and the cause of the crash.

The GP Display section option was/is set to Software Renderer. Are you saying that setting it to Open GL Renderer would be the appropriate setting for an onboard Iris display option? I will probably just try that and see what happens. Thanks again everyone for the fast responses, this Community is outstanding!


In some cases Software Renderer works better than OpenGL; for testing purposes I use both interchangeably and both work OK.

Great that you solved the issue! :slight_smile:

Ok, switched back to the onboard graphics chip and tried GP again on both software and open GL mode - GP crashed in both modes when a VST3 plugin from both Melda and Waves were opened (legacy rackspaces) or attempted to add to a new rackspace. Waves does have VST plugins as well but I don’t/haven’t used them since VST3s were available. To the best of my knowledge, Melda has only VST3s (in additon to other formats), and I know for a fact that Melda offloads some processing/graphics UI processing to videocards if they are available. Very interesting! GP and Melda used to work fine on my NUC, but I don’t know if that would still be the case.

OK, I removed your response as a solution. Is the crashing process the same?
It seems that this has to do something with the OpenGL system library on Windows.

Yeah, if I try to switch to OpenGL it crashes GP, which then reverts to Software Renderer when I restart GP. So, I can’t switch out of Software Renderer if my graphics card isn’t installed. I’ll reinstall my graphics card again and try Open GL mode to see if I can switch in that configuration.

When I try switching between Open GL and Software Renderer with my graphics card installed, it switches without any problems and I can’t tell there are any performance issues with GP using either mode. I can only conclude it is something specific to the Intel Iris graphics chipset in use in my CPU, which is an i9 11th generation “enthusiasts” CPU.

In any case, my immediate problem is resolved but not sure if this will apply to anyone else unless they have the same MB and CPU I have.

It also depends on your operating system, i.e. the current system’s state (installed software, runtimes, frameworks, … can also be one of the potential culprits).

Anyways, great that you resolved the problem for now! :slight_smile:

1 Like

It was all of them that I tried. Ditto for Waves. Of course there might have been one of them that would have worked but there are so many it would have been really tedious to try that. However, just trying to switch to Open GL rendering in Display settings crashed GP too. I just reinstalled my graphics card though and all is fine!

1 Like

Cool! Good that you got resolved. :+1:

1 Like

For the record, an update as to the final cause of the problem and resolution.

The CPU in the rig I am using is an Intel Core i9 11th gen 11900K that has an integral Intel Arc UHD integrated graphics chip. When I built the rig, I installed a NVidia 3090 Ti graphics card. The system knows what is plugged into it and disables the onboard integrated graphics chip and the 3090 graphics card is active.

When recently trying to upgrade to the Intel 23HD Windows 11 update, the installation would not complete and the computer would freeze when trying to boot up for the last updates to install. Trying to track that down I started switching between the NVidia graphics card and the onboard Arc UHD graphics chip. It was during that time I discovered GP would crash when trying to display the GUIs for Waves and Melda plugins. I went back to using the NVidia graphics card and all was fine with GP.

However, I still suspected it was a graphics issue that was preventing the 23HD feature update, so I switched back to the onboard Arc graphics chip and tried installing the 23H2 feature update from a dedicated media disk made as an ISO and mounted from the W11 desktop. It was at this time the installer noted that the graphics driver for the integrated Arc chip was not installed. Following the installation of the driver, the feature update completed without incident - AND GP would no longer crash when trying to display the GUIs for the Waves and Melda plugins.

In conclusion - the real problem was the lack of the proper driver for the integrated graphics chip on the CPU. It also points out what I have said many times about “choice” being both a wonderful thing and a curse, depending on the scenario and viewpoint. There is a universe of choice with Intel and being able to build your own devices, but also much to be said with Apple’s model of everything done/controlled by the manufacturer to insure the best customer experience out of the box.