Mapping tap tempo, what am I doing wrong?

Hello, I’ve been trying to use Global MIDI to map one of the pads on my midi keyboard to the tap tempo button but it simply won’t work and I can’t figure out why.

  1. I changed the setting of the respective pad to a midi CC (channel 1, CC 20). Then I made sure this works by using the global midi monitor of GP.


  1. Then I went to the Global MIDI window, chose the correct line in the menu and selected the correct midi signal by MIDI learn.

Then I closed all the options windows and repeatedly pressed the pad on the controller. The MIDI indicator in the GP window will indicate incomind MIDI data but the BPM value will stay the same and there’s no indication that the MIDI signals do anything at all.

Hi, tick the momentary button on the right :wink:

Sadly no change.

However I just noticed that it does seem to work when I use notes instead of CCs. This is a bit inconvenient though since it will likely produce interference with actual midi notes sent to my virtual instruments at some point. As I understand midi my interpretation does correspond to the orginal specifications (midi notes for musical information, CCs for controlling other attributes). Is this a bug in GP or is there any meaning to this?

No, this definitely works with CC. My personal setup is CC30 on a KeyLab 61MKII…

I use one of the buttons below the faders. CC30 is sent as 127/0. Are you using the pads?

Since your screenshot shows falling values for CC#20, it looks somehow like it’d be a configuration error…
Make sure you configure your pad according to the manual:

You never told us which keyboard you exactly use… so i just guessed it was the mk2 - maybe it’s the mk1 and this model behaves diffrent… i don’t know.
Make sure, the pad is set as “Gate” and the “ON” value is fixed as 127 while the “OFF” value is 0.

It’s the Keylab 49 Mk1 actually. Yes, it’s configured as sending continuous values. Maybe that’s the problem. However my expectation was that every value over 127/2 would register as “active”.

@schamass Not a strictly GP-related question but how do I choose the correct setting for the pad? In the MIDI control center I can choose the type of midi signal, the channel and the min and max value.


If there are no more options, this looks right to me.

But then there seems to be a GP issue after all because this setting does nothing when I map it on the tap tempo function in GP’s global midi menu.

(By the way the result is the same when I try to use a button on the global rackspace panel that’s mapped to the same function in the system actions plugin. The button itself works fine but mapping a pad on my midi keyboard doesn’t work.)

Did you try “control toggle” on your MK1?

Coud it be that this results from a single push on the midi pad? It woud meen that you have something like a “falling roll” activated. The good momentary configuration would be:

  • press your pad : a CC20 with value higher than 0 is produced
  • release your pad : a CC20 with value 0 is produced

“Control Toggle” means that you control an attribute with on and off states, doesn’t it? How would this made sense regarding a tap tempo trigger?

No, the pad is just configured as a “Control”. But yes, it indeed sends multiple (aftertouch) values per touch. :thinking:

That’s what you have to change to make the tap tempo work. Imagine you as a drummer to give you the right tempo and he gives you a drum roll instead… :grimacing:

Absolutely. I just need to figure out how to do that on my controller, seems to be a bit tricky at least. According to the MIDI monitor the Keylab doesn’t even send specific aftertouch signals but just a bunch of control signals with different velocities.

Nothing about roll of aftertouch in the keylab manual. Which model do you have?

  • Are you sure you don’t have any king of MIDI loop in your rig?
  • How did you connect the Keylab to the GP computer?
  • Do you have other MIDI connection?
  • Did you check what MIDI message is coming in from the Keylab using the GP MIDI monitor starting from a new empty gig?

It’s the Keylab 49 Mark 1 and I got it connected via USB with no additional MIDI appliances. My GP rig is clean, no additional midi plugins. I do have another midi keyboard attached. And yes, the Keylab always behaves the same, no matter which GP rig I use.

It is definitely a problem with the Keylab as it reports the same behavior on its display where it displays the last signal sent.

Then it is possible to filter out CC betwen the first CC>0 upto CC=0.

But perhaps you could test the other mode (latching in GP words, toggle in Arturia words) and don’t choose “momentary” when mapping the pad in GP.