Logic error when attempting to record GP to Logic via GP Relayer

Hello,
I am having some issues getting GP Relayer to work when attempting to record into Logic from GP.

As soon as I click record in logic playback starts of the other tracks but there is clicking and pops and shortly after that I get the logic error
Error while trying to Synchronize Audio and MIDI
Sample rate 45,112 recognized.
Check conflict between Logic Pro and external device

The other tracks in Logic originated from Farplay and they should be 48,000 Khz per FarPlay support as part of a multitrack recording session so I can’t understand what is causing the issue or why Logic is reporting a mismatch.

About my setup
When I record the multitrack sessions I normally have GP set to use the built-in Roland RD-88 audio interface and I connect to FarPlay with my Antelopeaudio Zentour to minimize audio artifacts when playing online using and this works well.

There was no mention of being able to use separate audio interfaces between GP5 and Logic Pro so I switched both apps over to use my Zentour and the primary audio interface before attempting to record into Log from GP5 and I did not create Aggregate audio device names though I was wondering if I should instead of pointing them both to to Zentour itself.

Is there a way to force logic to default any audio files dragged in to 48000 Khz or somehow get both programs to recognize this and the correct sample rate?
I am running a 2019 MacBook Pro 16 with the latest Sonoma version with 64gb ram and an 8TB storage
Any ideas welcome with this. It’s really stumping me.

At this point playback is still running but the recording bar has stopped in Logic.
There is a continue button that I have to click before I can stop the recording.
Having both Gig Performer and Logic running at the same time using the same audio interface seems like this could cause some issues but I don’t have any other ideas of what could be causing the problem
Any Ideas what might be causing this?

I made some progress since the first post.
After deleting the audio files from the example files posted I was finally able to get the logic demo file to save with 48,000 khz not changing back to 41100
I recorded a new snippet of audio directly into Logic and I can now get audio from Logic back to play back in Gig performer with GP Relayer using GP Relay # 2 so success finally on that.

I still haven’t been able to record audio from GP5 into a logic track with GP Relayer on with GP Relay #1 When I attempt to record into Logic all that I see after I stop record is an audio file with no sound and just a flat line in the middle.

Also

The pdf’s show that the ‘Local Host Is Active’ Light should be Green on the Logic
GP Relayer receive but mine is not.
Input Monitoring is Checked on the Channel and so is Record
Only Send Active and GP Application are Green

Is there a problem with the feature with GP5 and Logic?
I there something else need to get audio from GP5 to record successfully into a logic track?

I’m not a Logic user normally, but I also struggled using the example Logic file as I also run at 48kHz. It was much easier for me to start from scratch.

Problem 2 is I don’t think the current instructions are complete if you want to record. Yes, you can get audio coming into the track, but Logic is recording the track input device, not the output of GP Relayer. To record GP Relayer, I needed to route it to a Bus, and then have a second audio track that had this Bus set to be the track input.

2 Likes

Hi Rank13,
Sorry I haven’t got back with you sooner but I wanted to try everything from your examples and others before troubling you further.
It bugs me that I haven’t solved this by now.

I have a Logic Pro 11.1 Template created with your examples from scratch.
I tried to upload my logic template file but this editor won’t let me select the file.
I would like to use two GP Relayer inputs and have the correct number of tracks needed and I see both Aux 1 and 2 in the list too.
There still appears to be a problem (broken link in the chain) somewhere in between where GP Relayer sends audio from GP5 and where is is supposed to show on the Logic tracks with Input monitoring enabled.
I see and hear the output on the GP 5 side from relayer send but it just doesn’t make it to Logic for some unknown reason.
Any other idea’s what could be stopping this from working?
Mac OS is Sonoma latest version.
Thanks in advance

If you zip/compress the file you should be able to upload it here.

Default GP Relay to Logic Recording.logic.zip (585.3 KB)
Thanks Rank13
I tried initially changing the file to pdf but that didn’t work.
Uploaded zip file of the logic file.