Lemur and GP3

#1

Hello,
I just downloaded and loaded the new Lemur GP3 template. I have the buttons working - the setlists / songs / parts switch just fine, but no button labels are loaded. Do I have to do anything extra to make this work?

Thanks!
Václav

#2

Two questions:

  1. Are you certain you have bi-directional communication working?
  2. Have you assigned the correct OSC names to your widgets?

Check the following section of the user guide

https://gigperformer.com/docs/userguide/lemurtouchosctemplates.html

#3

Hello,
what I’m after now is just the basic Sets / Songs / Parts switching. No custom widgets needed so far.

So, I downloaded the template, loaded it to Lemur, added few sets / songs in GP3, set up the OSC and checked the Lemur checkbox.

When I click the buttons on my tablet, the sets / songs / parts in GP3 do switch. However, I don’t see any button names in Lemur.
Also, when I switch the set / song in GP3, it does not switch in Lemur, so there indeed seems to be some problem with the bi-directional communication. Not sure what to do with that or how to debug this.

Thanks for help
Václav

#4

Please review this documentation from our user guide

https://gigperformer.com/docs/userguide/osc_tutorial.html

#5

Occasionally my laptop network adapter forgets my static IP address and reverts to auto DNS. When that happens data is sent to my iPad but nothing comes back. When that happens I just have to go in to the IP4 properties of the network adapter and re-enter my static IP address.

Other than that I can say that Lemur and GP are working flawlessly together using OSC. Liine says you cannot use a wired Ethernet connection with OSC but that’s not true. I am running over an Ethernet cable and it is fast and reliable for live performance.

#6

Are you using a WiFi router?

#7

Hello,
got this working, my Remote settings were wrong.

Thanks!
Václav

#8

No WiFi router at all. Hopefully it’s not unique to my setup but I happen to be using a newer iPad Pro and a Windows laptop with Thunderbolt 3. The iPad Pro has a USB-C to Ethernet adapter — that is needed to allow iOS and Lemur to recognize a wired port. I plugged that in and went in to the Ethernet settings on iPad and set up a static IP (192.168.12.7).

Because my laptop has no Ethernet port I had to buy a second USB-C to Ethernet adapter, plug it in and set it up with a static IP address on the same subnet (192.168.12.12). I am assuming if your laptop has a port you don’t need the second adapter.

One quirk about Windows and those USB-C to Ethernet adapters, each adapter is uniquely identified by the OS and they show up as separate Ethernet adapters. Picture that I have an Ethernet cable with the same brand/model adapter on both ends…now picture arriving at your gig and you’ve turned the cable around so that the “other” adapter is now plugged into the laptop. Windows 10 sees this as a new Ethernet port which is probably not set up with the desired static IP address. So the iPad receives OSC data but the laptop does not!

Solution, of course is to take the extra time to program the same static IP address with each adapter plugged in to the laptop. Windows will warn you and suggest that you delete the older assignment so you need to NOT do that and allow both to use the same static IP address (fine since you’ll never have them both plugged in at the same time!).

I’ve been running live like this for almost six months and it works like a dream. Even the Lemur Editor running on the PC works.

#9

That’s probably not a quirk. An ethernet adapter has a unique MAC id so if you have two of them, you’ll have two separate MAC ids, which is why Windows sees them as different.

#10

And the iPad doesn’t treat them as unique even if it knows they’re different. Presumably because there is only one hardware port so no chance of having multiple adapters plugged in. Good to be aware of!

And not a surprise but the wire is SO much more responsive than wireless.