Last night's first GP gig (and my 3rd gig ever)

So, I am going to try to make this not a rant. I do love Gig Performer, I think it is amazing on many levels, its exactly what I want. I’m going to keep using it despite what I just experienced with it. Yet, last night made me wish I’d programmed my hardware instead.

I’ve spent the last 3 months building rackspaces and practicing to audition for a popular local band. Their keyboardist left so this is a HUGE opportunity to get into a regular gigging band with lots of great bookings already for the year All the others I’ve joined start spinning up and fizzle out for one reason or another — not that I haven’t learned things from that, or gained from some of the intense practice that went along with preparing for gigs (that never happened lol). So this is it. Pivotal moment in my music journey, and I’m feel I’m comfortable enough to use Gig Performer. I’ve got 30 years of experience in troubleshooting IT workstations. I’ve got a backup. Hell I’ve got 2 backups. Let’s go!

Anyway enough backstory — so here’s what happened.

I practiced hard yesterday with no problems. I saved my GP file, I shut the application down properly. I restarted Windows once to make sure no sneaky Windows updates were going to happen or anything of that sort - just a clean reboot to make sure it was likely to boot when I arrived at the venue. I shut it all the way down, packed up my rig, and arrived 20 minutes later to the gig.

Fast forward to soundcheck time. Previous to soundcheck, I confirmed the MIDI light lighting up in GP so MIDI was working, right? Or so I thought. This is what threw me off a bit on trying to identify the problem I was about to have. Fortunately, we started soundcheck 15 minutes early, or this might be a completely different story. More on that later. Now, I didn’t bring the USB hub — I figured I’d just plug into the laptop directly. It has 3 USB ports, I only needed 2 for the MODX and the Fantom 7. I played, and no sound. First thing I checked was the mixer meter in GP – no sound. I checked my Global Rackspace where my compressor is — no meters. So no sound is coming from GP, or at least, that’s what I am assuming — MIDI is fine as it is receiving MIDI info. I start and restart the app. I reboot the PC. I power off the Fantom and back on. Nothing.

Ok, time to get serious and quit screwing around — I played an MP3 file. Sound works through the Fantom and its interface. I checked GP preferences to make sure the interface was identical to the one playing the MP3 file – yep looks good. Started getting a little frustrating, the gig starts in 18 minutes now, but OK – how about I load a different GIG file. I did – it worked!! So the problem is not the GP application, its with my gig file. Here, I remembered, I took a backup of the GIG file to the desktop before I left AND I had accidentally opened the gig from that location — could it be that? I opened the original GIG file from the GP folder — well that one didn’t work either. What is going on?!

Then I examined the rackspaces more closely and noticed… none of the MIDI Inputs had the Fantom or MODX labels on them. In fact they weren’t OMNI either, they weren’t anything. They were completely empty, generic-looking MIDI Ins. Also, it wouldn’t let me swap any of them for another interface, so I had to create a new fresh MIDI Input for the Fantom, reattach them to the instruments, and lo and behold - it worked. Relief - I found the problem. And then, alarm ---- all my splits, my transposes, any other info I had set in those interfaces — gone. And the gig starts in 18 minutes. But — as luck (and unluck) would have it, this was a sort of ‘trial run’ for me to prove myself capable of holding my own as this band’s keyboardist (that’s going well now, isn’t it?). Therefore the 1st set didn’t have me playing till the last 8 songs, then a 20 minute break between sets. I set to work. I set up all the MIDI interfaces the way they were, splits, transposes, and all. I was able to get Set 1 ready within the 18 minutes and then come up to play it — whew. I finished up the remaining ones (some of which had some fairly complicated splits/layers/tranposes) during the 20 minute set breaks. I was able to successfully finish out each set and the band seems to have not held it against me, everyone uses computers now, especially the sound guys — they run it all on a laptop and IPAD so you can imagine what they sometimes go through. And, I performed many of the songs “better than they had ever heard” from all the keyboardists they’ve had in 10 years. RELIEF… 40+ hours of practice in 2 weeks paid off, lol.

At this point I can only speculate what happened. Did it corrupt my MIDI Ins because of the USB hub move to direct connection? I wouldn’t think so, as I had done this before at least one other time and it worked fine (like when I first auditioned with the band, which led me to this live “audition”). I really have no idea how it happened, but I’ll never forget how frustrating and humiliating that was. I’m very concerned it will happen again. And no, I didn’t have a backup laptop, but would that have saved me? I really do not see how.

I know this is not a super feel-good story (though I still won the struggle in the end, hah!) and that this is not everyone’s experiences. Nevertheless, I suspect I’m not the only one this has happened to. I’m mainly posting this experience to see if it has happened to anyone else and what, if anything, can potentially be done to keep it from happening to me again. And again, what irks me is I specifically took a backup of this file, and I didn’t load the original till much later. How could BOTH files have corrupted like this?? Was it the USB hub vs direct connection? That was the only change: I didn’t bring the hub. I think that was the issue somehow, but, again, I had no problems when I went from hub connection to direct when I went to the initial audition for the band. Honestly, if it had occurred then, I would be much much angrier about this. GP failed me pretty hard when it counted the most, fortunately I had the wits (after 10 minutes of scatter-brained embarrassment) to calmly isolate the problem in the nick of time

The upside is, despite the problems, the band did invite me to their next gig, and to do the full gig this time. They loved the performance and sounds I came with, and that’s what matters on the end. I am going to switch to an actual audio interface and use the MIDI interface instead of USB. I was going to switch to midi controllers anyway, so perhaps this is the way to avoid all of this. Curious if anyone has had a similar experience, any comments or questions, suggestions, etc. :slight_smile:

Hi @dirtforker and welcome to the GP community forum.

If you still have the unmodified backup of your gig file, it would be interesting to try to reproduce the same conditions (remove the USB hub, etc…).

I suppose your MIDI interface were identified differently without the HUB. This is typical from Windows so I suppose you are on Windows?

The solution is to use the Rig Manager, I guess you didn’t do it?


So basically – you did all your creation and rehearsing with GP but when you went out to play, you used a different configuration and since you didn’t use Gig Performer’s Rig Manager, which is designed specifically to make it easy to switch configurations, you got into trouble.

I know you feel like you would have been better off with hardware but to use an analogy, It’s kinda not really any different than if you rehearsed (including sound design, splitting, layering etc) with a Korg Kronos and then showed up at your gig and they handed you a Roland Fantom!


So basically - yes, I am completely ignorant of Rig Manager!! :slight_smile: I’m pretty new to Gig Performer. I guess I assumed a USB port was a USB port wherever it would be. For example, Windows doesn’t care where I plug in my Fantom - it works where I plug it in every time. I thought the application in turn would take the queue from Windows, but I can see how it gets more complicated than that from a precise routing standpoint in an application.

I’m going to look into it and start using it for the next gig. Thanks much for the replies!

With Rig Manager, the idea is to define generic MIDI Device Alias name, like piano_88 or upper_73 or whatever you want. Hence you will use generic MIDI in blocks piano_88 or upper_73 that could be replaced at the very last moment in case you broke a keyboard controller or because your MIDI port name has been changed by Windows. Rig Manager make it then very easy to « learn » the new hardware and your gig will work seamlessly. You can prepare in advance a rig for your home, rehearsal room or whatever and add one on the fly if necessary.

Good news for your existing gig file, once Rig Manager is properly configured, GP will help you to replace the regular MIDI in blocks by Rig Manager Device Alias Names MIDI in blocks.

Have fun with GP and please read the manual before your next gig, what you did was risky :grimacing: :wink:


Thank you, I appreciate the expanded explanation!

Yes, a hard lesson that I myself have suffered. Not just MIDI but any USB device will be reconfigured if plugged into a different port or hub. For most devices this is irrelevant (mice, keyboards, thumb drives, etc.) But anything less generic can cause problems. At least GP has a solution with Rig Manager.