Kontakt 5 and Scaling

#1

Lingering question that has recently become a major annoyance…

I’m on a 13" Lenovo Yoga 720 laptop. Plenty of horsepower for what I need to do with GP.

On GP2, I had a weird issue where Kontakt 5 would open up in a box too small (regardless of if I opened it via edit plugin or double clicking in the connections window) for me to see the controls. Normally I could exit the window and open it, wash/rinse/repeat about 2-3 times and low and behold, it’d open up right. i.e. with a window where I can see the whole Kontakt instrument and browser.

Upgrade to GP3, and I’ve been using older gigs and not had to make a new one/edit anything in the plug in and not in the widgets, so I haven’t seen this until now when I need to make a new chart.

I open Kontakt 5 (just make sure both it and GP were most up to date) and… it’s a tiny window. Except this time, no amount of closing and opening can get windows or GP to make a big enough window, OR scale the DPI correctly.

My scaling was set to 150% because… this is a 1920x1080 panel in a 13" body, and that makes everything TINY on the screen.

The ONLY was that I can get a Kontakt to open up with a window big enough to see everything is if I set my scaling at 100%. But now everything is super small. Here’s a picture of what I see.

Anybody got any ideas? I’ve been at this for too many hours already.

0 Likes

#2

You could hide the library window on the left side.
This is an option in Kontakt itself.

0 Likes

#3

Unfortunately, there’s no way to scroll to the side of the window where I could hide it. The only scrolling is down the library list.

I compared GP3 settings with my GP2 settings in the properties compatibility window, and the only main difference seems to be that GP2 has the option to “Override high DPI scaling behavior” unchecked. This option is greyed out on GP3 – odd because every other program on my computer has it capable of being (de)selected to give the drop down list.

It appears that now, even having gone back to the settings I was using at 150% scaling, using windows DPI, etc, now NO edit window in any VST or 3 (aside from some smaller effects) opens up with a full window. Even VB3ii in VST3 opens with the bottom of the drawbars cut off.

I’m so confounded.

0 Likes

#4

Ok, just so it’s clear what this looks like, I’ve uploaded several screenshots for different plugins from different companies.

Somehow, I got Garritan’s Aria to open up normally. But that was the only one. Even some smaller effects (like NI transient master) came up half way open.

Of note, these windows are not re-sizeable. There is also no scrolling capabilities available; for example, a two-finger swipe left/right/up/down on the touch pad does nothing.

At this point, I basically have to create song parts as different parts of a rig in GP2 and import them into 3… and hope that nothing gets lost in translation… I’d really prefer to use GP3 as designed, without having to change DPI scaling on my main screen every single time I open up GP3.

This generate any other ideas?? Has anyone else experienced something similar on Win10?

0 Likes

#5

I assume this is the latest v3.2.7 right?

We’ve tried to use a high density screen on a Windows Surface where the “recommended” value is 200% scaling. Changed that to 150%, then also tried on a normal screen with 150% scaling without success - the windows always come up with the correct size.

I also assume you are running the latest Windows 10 since there was some significant updates in handling the DPI stuff.

0 Likes

#6

That is correct; version 3.2.7; with the latest Windows 10 creator update.

I did end up finding a work-around. Recap:

Running a 1920x1080, 13inch touch panel. It’s the generic UHD 620 intel integrated graphics on an i5 8250U chip.

I had to change my scale to 175% and then unlock the taskbar. The 175% scaling somehow took care of the window size issue. At least in that they’re full. The issue now was that I couldn’t see the bottom bc of the taskbar. Once I unlocked the taskbar and moved it to the side I had a view of everything.

Kind of a backwards way to do it, and it still doesn’t change the fact that I cannot override high DPI Scaling behavior via the compatibility tab (like I can with GP2). Well… I could probably hack it via the registry, but I really don’t like doing that to this computer.

At any rate… at least I can see it!!!

0 Likes