Issue with audio from global rackspace


Setup of global rackspace

  • Block “From rackspace”, midi connect to Kontakt 7 instrument
  • Kontakt 7 output to channel 1 and 2 of a “To rackspace” block
  • Block “From rackspace” audio channel 1 and 2 to a “Gain” block and “Audio out” block

Setup of rackspace

  • Block “From global rackspace” audio channel 1 and 2 to a “Gain” block for volume
  • “Midi in” block connected to “To global rackspace” midi

The setup works perfect most of the times, but sometimes, after changing a rackspace the audio level is louder. I have tested a few things.

In the rackspace:
Disconnecting the midi in block results as expected to no midi and no audio.
Setting the “Gain” block, connected to the “From global rackspace” to infinate should turn the volume output down, but altough the volume is lowered, there stil is audio going througn
Disconnecting the audio 1 and 2 in the rackspace from the “From global rackspace” has a strange result, there stil is an audio signal. This should not be possible since the audio outputs from the virtual instrument (Kontakt) in the global rackspace, only connects to the “To rackspace” port.

I hope the recording helps to see with the audio paths whats happening.

This could mean that there is something in the new rackspace that is getting directly routed to your audio out in a way that isn’t happening in other rackspaces. Look over your routing carefully.

Hello, thanks for the reply.

I hoped the video shows all connections, there is no alternative pad. Also, when switching between racks it is not always the case. Sometimes its fine, and other times it’s not.

Sometimes its just as if there is a inner connection from the box “To rackspace” and “From rackspace” in the global rackspace. But as i recorded, there is no connection. I will try to make another video while switching two rackspaces so it shows the differences in audio levels.

I hope it makes sence.

There’s no magic. If the levels change when switching to certain rackspaces and not others, then there’s either something routed directly to your audio out in those rackspaces, or there are widgets there that are connected to parameters in the Global rackspace that change value.

Are you using setlist mode?

Do you have any widgets connected to anything (gain or mixer)?

Is it possible you saved a snapshot of that change (in setlist mode)?


I am very glad with the suggestions! In the video it’s missing audio, but it does show the connections. There really is nothing else connected within my knowledge. And yes there are widgets connected, but no snapshots. And also, then i would expect it would always behave the same. So why is this not the case.

I will try to create a more detailed video. I have tried so many things, created a new gig file, disconnecting audio lines and stil the audio just passes through. I really don’t know how this behavior can be explaind. But it will take me some time.

I have created a video of the problem. Runs about 2 minutes.
It demonstrates the setup of global rackspace, rackspace and setlist with images. After that there is a live demo where i switch between two racks and show a strange behaviour of the audio path coming from the global rackspace.

I really hope someone takes some time to look at it and have suggestions.

My setups are much simpler. I can’t really get into all the weeds here but maybe this will help.

I would try to isolate the issue further.

The strangest is the notion that the piano audio is getting out even when it seems to be be routed out.

So, it seems like the piano is sometimes played twice (doubled), which could explain why it is sometimes louder than it should be.

In addition to looking carefully at the routing, you could try to isolate the issue further. (It is so unlikely to be an issue with GP, that I would put that out of your mind for now).

Go back and forth in changing song parts and change songs. Is there a pattern when it is louder and not louder? That might lead you to an explanation/fix.

Also, compare changing songs and song parts to changing rackspaces. Does it still occur? Is that a pattern.

Then maybe see what happens when you trigger the note in the midi in block and in the plug in itself. How is that different?

Might as well use the midi monitor to see if that shows anything (double notes).

Hope this helps a bit.


Can you upload your gig file here?

I think I know where the problem stems from because I had the same exact problem. I think it has to do with patch persist in the local rackspace. Basically it’s “patch persisting” your global rackspace audio signal within the local rackspace which is doubling your audio signal (new local rackspace audio plus whatever is “persisting” from the previous rackspace).

Try turning off patch persist on your local rackspaces as a test. See if you still get the volume issues.

If I’m right about this we should probably put in a feature request for the local rackspace to have an option in which patch persist does not affect the “from global” audio signal.

1 Like

Yes, super. This is completly true. As soon as i turned of patch persist the problem dissapeard.


It apears to be a real problem. It happens al the time when using “Patch persist”. I would really like to use a few instruments in global rackspace but now i have to turn of patch persist almost everywere which gives issues with switching sounds. I hope a fix for this will come soon.

You’re right. My mic signal is sent from the global rackspace to the local ones so I can further process it individually. I’ve also noticed that this audio is sometimes doubled by patch persist and the bad thing is that it doesn’t seem to stop after the time set with “input fading”.

The way I’m dealing with it is having a script in each local rackspace that mutes the audio input from the global rackspace when I switch to a new rackspace (with the “on deactivate” callback).

hmm, thank you. I also use this for my microphone signal. So i have to check that one to.

Can you please explain a bit about the script? Or care to share it?


Sure. Suppose you have connected this audio coming from the global rackspace to a gain control plugin in your local rackspace. Connect a widget to the mute parameter of this plugin to mute and unmute the signal.
Give this widget the name (called “handle”) “Mute” and declare it in the local rackspace script:

    Mute : widget

We want the script to set the widget to mute when we “leave” the rackspace so we use the callback “on deactivate”.

On deactivate

That’s it. You need to do this for every rackspace that uses your global audio.

1 Like