Internal MIDI IN plugin's keyboard doesn't work properly

This has been a problem in the Windows version for a while, so I’m finally mentioning it. When you click a key, on an internal MIDI IN plugin’s virtual keyboard, no MIDI is sent to the output unless you MOVE the mouse while clicking. In other words, you have to DRAG the mouse across a key (or keys) in order to hear notes.

This is a problem on both my Windows desktop and my Windows laptop. On my MacBook Pro, the keyboard works correctly when you click a note.

Thanks for this report. This is something we already mentioned to the devs, so all you have to do now is to wait for a future GP release :wink:


Another thing worth mentioning is that the computer’s QWERTY keyboard triggers MIDI notes when the MIDI IN plugin is open, but only after you’ve clicked on the virtual keyboard. Would be nice if you didn’t have to focus the virtual keyboard first. Same issue on MacOS.

I have never noticed this. But there are several apps that have this function for entering notes from the QWERTY keyboard.

EDIT: And they will even play the plugin that is connected!
…if the MIDI plugin is open and the keyboard is clicked on.

What should happen if you have multiple MIDI In blocks open?

The MIDI IN block that is open and focused is the one that should respond to QWERTY keys, as it currently does but only after you’ve clicked on its virtual keyboard. I’m just saying you shouldn’t have to focus the keyboard control itself, on the block, in order to get this to work. Just like you shouldn’t have to drag the mouse over the keys in the Windows version.

Better to use is a virtual keyboard like Midikeys on Mac.

That may be, but I like the quick-and-dirty approach of the internal MIDI IN plugin which is always in the signal path, so I don’t need to add anything else. I don’t want to clutter up my on-stage rackspaces with a plugin that I would only use for testing.

Virtual Midi Keyboard is not a plugin.
And with that you can simply check your correct splits and ranges set in the different MIDI In blocks
and (!) you can check with different MIDI channels

For example with such a setting you will not get any MIDI note when you use the inbuilt keyboard

OK, I guess technically it’s a block, not a plugin, however it is listed in GP under the available plugins you can add to a rackspace. Regardless, it’d be nice to see it working the way it was intended. Yes, of course I can check splits and ranges by clicking (dragging, in the Windows version) on the virtual keyboard. The dragging is not ideal, and the way the QWERTY feature works could be improved. I’m not really looking for alternative solutions.

There is a misunderstanding, I was talking about Midikeys

Ah okay, yes, for this purpose I don’t need to use MidiKeys

I always use Midikeys as the inbuilt keyboard has a limited range and you can check your splits while playing without the need to change the focus on different MIDI In Blocks.

I do have a Mac app called vmpk that I like. As for MidiKeys, there doesn’t seem to be a Windows version.

Could be

I believe that that issue is already reported and will be addressed in a future update.

Virtual MIDI Piano Keyboard ?

1 Like

Ah, nice, the Windows version of vmpk, thanks! One thing about these external MIDI-keyboard apps is that you still have to add an additional MIDI In plugin to your rackspaces, for loopback MIDI. On the Mac it’s the IAC Driver, and on Windows it’d be something like Hubi’s MIDI Loopback. For me it’s not ideal to have to add something extra to each rackspace, and an extra app in Windows, when all I want is a quick test.

Do you know Rig Manager?