Instrument Range Chooser

Just replace the plugins in the Gig File I uploaded.

OK, so when I double click the “MIDI In,” up pops that stylish interface with the snazzy “keyboard split” on the left side… with the “picket fence” (to show that it is selected).

In your example, you have a piano … and a bass … and the bass has the “picket fence” around it…

But when I try that, the piano interface (Scarbee, on Kontakt in this case) pops up - and no more “MIDI In” interface. Either single or double click on the Scarbee = same result.

Yours seems to be “combined…”

How to achieve this?

Thank you!

Sorry, I did not get it.
First replace the VST Plugins with the plugins you use.
Is that working?

Oh … you mean somehow load your “gig” instead of the “gig” I have?

I actually have a whole bunch of plug-ins (various iterations of them, at least). It took me a while to do it. Is there a “script” or something you used?

Remember, I’m brand new at this…

I should note that I’m using my Windows machine for this writing … but my Macbook Pro for GP.

I guess a “gig” can be “imported” on GP?

Yes you load load the gig-file I uploaded

I have a Learn Split Scriptlet in this huge gig file. It makes it possible to MIDI learn the split without having to leave the panel view.


OK … I will try that, then replace with my instruments.

Regarding the crossfader depending on the note played with regard to the split point (or overlapping range), I remember that @dhj already made a GPScript for that, even with a recorded demo if I remember well, but I don’t find it anymore…

I will try this too - This is essentially my goal as well, since I purchased my new Macbook Pro instead of a Nord Electro 6D.

I only have the Numa Compact 2X for the moment. It is portable and light. I will be using this set-up in NYC and taking public transpo, so a heavy keyboard is not an option for me. But the Numa lacks a lot of controls. Only the 9 drawbars and three rotary knobs seem to have MIDI implementation (lots of other buttons and knobs don’t appear to have it).

Maybe he will post it - Pianopaul’s does this…

Many GP users use the small Korg Nano Kontrol stuffs…

Like this one?

Yes, this kind of controller.

It works, but

  1. The Numa Compact 2x keyboard doesn’t have enough workable knobs, and

2 The “MinNote” keeps going back to 4 by itself.

For bass, I could just eliminate the “MinNote” and just control “MaxNote” from the computer…

when does this happen?

Something is wrong with your configuration

What is a “widget group,” and how does one implement this feature?

Does this enable multi plug-in control by one widget?

If not, is same possible and, if so, how?

Also, when I use “MIDI learn” to set the key range, it works, but doesn’t “stick” and it “forgets” it.

How to make the key range “stick”?

Thank you…

Cool. Thanks. I cannot get the MIDI In keyboard range limit to “stick” and reverts - actually, it doesn’t revert to full white keys, it reverts, but to full greyed out keys and this produces no notes sounding. I don’t see a “save” feature on the MIDI In pop-up.

So, while I can limit the range of the bass, it reverts back to full (greyed out).

Any solution?


Can you upload a small gig file to show the issue?