Inconsistent Sound Output GP4/Mac Mini

Don’t connect the Presonus to an usb hub.
I’m using two Presonus studio 26c (rehearsel/home) connected to a Macbook Pro and using the rig manager to manage these.
Never had any problems with this configuration.

I use a Presonus Audiobox Go. I don’t think I have had any issues with it.

I hesitate to post since I do not know too much, but…

You are using VSTs within GP and you also have audio running from your keyboard (Motif F88) into your computer and into GP?

So do you have any problem if you just use plugins without running your hardware keyboards into GP?

[Feel free to ignore if I am totally missing the point].


I am using a Nord and its sounds as my lower keyboard. The arturia controller is being used as my upper keyboard (replacing a Kronos which is flaky).

On my live rig, I use a keylargo device to mix the sound from the keyboards and feed it to FOH over the XLR outputs, which has worked well and functions as a DI box for up to 3 keyboards. the Nord goes into input 1. At my first gig I was trying to use the key largo as an audio interface, and had a usb cable connecting the mac and radial. When set to live mode, It acts as a 4th channel with independent volume control - but at the gig it wasn’t producing sound.

After that negative experience - I’ve tried adding a dedicated audio interface inside the rack and running 1/4 cables from the output ports into input 2 on the key largo instead. I’m using the Presonus for that now, and experienced the no sound output issue with that after a reboot last night.

I’ve taken the presonus out of the hub and have it plugged into a dedicated port on the mac. Currently I’m using it for two purposes: as the audio out for the VST and as a midi interface with my iPad - to receive program changes from For Score, and transmit CC codes back to For Score for moving forward a page, etc…

I’m wondering if GP might get confused by this somehow? I could try just using the preonsus for midi and use the keylargo for sound or vice/versa to see if that helps resolve this - or maybe come up with a different way of sending mide from my ipad to GP.

My only relevant thought is that I have one audio interface (Audient iD14) that I connect to a laptop that I use for things other than audio. Every time I power down the laptop (which powers down the interface because it’s on USB power) it comes back up silent until I open the Audient control panel and change my output levels again.

I don’t know if that’s a function of the iD14, the drivers, the laptop, or something in my configuration. I haven’t bothered to try to diagnose it. I just know to go back and adjust the levels again every time I reboot.

I have no meaningful experience with Presonus interfaces.

GP will not get confused by this, specially if you’re using the same interface all the time.

MIDI and audio are handled completely differently. I think you need to determine a few things first…

When you play your MIDI controller to trigger VSTs which are (presumably) connected to your audio out block, do you always see the audio output meters at the bottom right of GP flashing? (see image below)


Here’s how I’ve got GP setup. On the Rack side - I have starting templates that can support 1, 2, 3 or 4 instruments, which I can just import and customize. Most of my patches just need a simple 1 instrument, but I’ll share an example using two. On the front I just provide a volume fader tied to a mixer and 3 faders which allow for a global chorus/reverb/delay to be used if wanted:

The wiring for this is pretty straightforward - I simply run the mixer into the global rackspace, and branch the outputs over to the gain controls for the chorus/reverb/delay which are sent in seperate channels to the global rackpsace.

On the global side, I adapted the global rackspace shared by another user - mainly adding a pink noise control and some buttons to control the page/song changes to forscare, and a second program forward control I can use with a foot pedal.

It has 2 a mixer for the incoming audio, with a mute buttons - and faders tied to the audio interface output volume and level controls.

For the wiring side I route the audio from the rackspaces channels 1-4 are used for the raw incoming sounds and fed into the mixer, and channels 5…10 are split into the chrus/verb/delay effects. Everything is wired to the stereo outputs of the audio interface. There are also some midi connections that allow the ipad to send/receive program changes and cc control codes into gp and through to my external nord keyboard.

When it’s working, I see fader levels working on the rackspace, and the global mixer and interface output, and the gp audio indicators in the lower corner.

When I experienced no sound output at the gig and in my home last night. The faders in the instrument side are still working, but the interface output levels are dead, which indicate that GP knows it’s not working.

Using the gig performer audio menu and switching to a different audio option and back was the only way I could get the sound to return.

For the Presonus, it’s control program doesn’t offer any sort of volume control. Another user suggested that some audio interfaces might boot up in a muted state - I don’t know if that’s the case here - All of the gain knobs had not been touched from where it was working.

I’m willing to try out a different interface - I’ve got a Focusrite available, or I could try something else like a Motu or M-audio as suggested by several others. it’s strange that it would fail with two different ones so far, so perhaps there’s something wrong in my gp wiring or configuration…

Well, according to the images you posted, GP is configured for the Scarlett already.

More importantly, you did not answer my question above

Yes- I hooked the scarlett up to my laptop to show my configuration. I just booted up my live rig and at startup - it’s in the state where there is no sound coming out of the Pre-sonus again.
For reference- the output device is setup to use the Presonus in the menu:

Screen Shot 2023-03-24 at 12.27.18 PM

And when I press notes on my controller - the instrument side is showing fader activity, but the global rackspace output meters as well as the gp

meters in the bottom right are not flashing at all:

What if you did a simple rackspace without using the Global rackspace? Any difference?

And for reference, the Universal Control software for the controller isn’t showing any problems, there is a mute option, but the setting is turned off (I tried toggling it on then off with no effect). This device doesn’t have many configuration options. My computer has two USB 3.1 type A port - so maybe that’s a factor

OK - that is a clue that audio is not reaching your audio interface.

Can you open that Audio Mixer in your global rackspace and see if its meters in that plugin flash when you play something?

I just tried that - I opened up the 4-channel mixer from the global rack wiring screen and played some notes. The meters are showing activity there, and the midi indicator was flashing. There was no sound or output activity in the lower right, though.

I gave that a try - just created a simple rack with omni midi going through a piano instrument and directly into the Presonus outputs and still no sound.

I would think that is an easier one to work on. (Even I can try to troubleshoot that!).

Then I would look if you see midi activity and audio activity in all the places it would show up. (David or someone could walk you through this better than me). [David, if I am not being too helpful, let me know. no worries].

After doing some more troubleshooting, it seems that I’ve just had some bad luck in choosing Audio interfaces. The presonus doesn’t seem to work reliably with the M1 / USB 3.1 MAC and the radial keylargo is starting to act up - it cuts off the XLR signals when I plugin a cable to the monitor out, which is a new problem for it. I’ve reached out to radial for help, since it’s still under warranty.

In the meantime, I’ve ordered a Motu interface from Sweetwater and will be incorporating that into my rig instead of the Pre-Sonus. Thanks to everyone for your responses and time to help sort out this issue.

1 Like

Which MOTU did you get?

I went with the M4. Thanks again for all the time and help today.


Cool, I’m glad that you went this route.

You should simply plug your Nord into that and route the Nord audio through Gig Performer, thereby getting rid of that Radial Key Largo (which seems to have tons of problems).

Please report here how it works! :beers:

1 Like

Sorry you went through that. Hopefully that will fix everything.