I´m losing "Blackhole 16" again and again. How can i bring it back w.o. a powercycle?

Hello community,

my query is in the header: how to bring blackhole16 back to live after “losing” it ?
(looking for something quicker than a power cycle of my mac )

so, i had the last 2-3 Weeks 2-3-4 incidents, when i would “lose” Blackole-16.
But “right now” its just too often. ( just installed 2 new plugin FX. not shure if this has a relation)

my main ( the music making) GP instance is set to, audio Interface:

  • IN: Blackhole 16 / or nonne
  • Out: blackhole 16
    sending GP-1 to a second GP instance, and from there to my audio interface.

my second GP:

  • IN: Blackhole
  • OUT: my audio interface ( presonus Q2626)

So, when i “lose” blackhole, …the errorr message vs. GP is: audio disconnected, GP turns red.
I have then the Blackhole16 nolonger anywhere available in my system to select it.
Its like it was gonne from my system.

So my Query is:
is there a way to bring it back without restarting my mac ?
( a power cycle helps, and solves the problem)

i´m not necessarily asking where its coming from.
i´m really just asking if there´s a quick solution to bring blackhole16 back to live ?

When you ‘lose’ it, is that while you have an active gig file and audio passing through blackhole? It sounds like it could be crashing.

The blackhole GitHub page mentions restarting of core audio. You would do this with GP closed. I’ve never used/tested this.

restart CoreAudio via terminal using
sudo launchctl kickstart -kp system/com.apple.audio.coreaudiod

I think you need to find out why you’re losing it.

Have you queried the Blackhole community?

1 Like

yes, this.

i was not aware that “blackhole” could crash. But it “feels” exactly so.

I was also not aware of this. That gives a good “keyword”

ahh, thats interesting !
i will give this a try, the next time !

Much thanks @rank13

I was not aware that such a community exists. Found it !

i have a (strong) guess:
i would say it´s a good bet that there is a relation with the ACE Driver from RogueAmoebas “Audio Tools”. i do run “Loopback” at the same time. Sending multimedia from my web browser also to my 2nd GP-instance. (which is in fact cool as f.ck to do it so :wink: / gives me EQ + Comp with a one knob HW control, plus HW volume control )

thanks for caring @dhj

ok, happened allready again. I tryed your terminal command.
(in short: worked at second attempt ! )

interesting, The story:
my second GP instance turns for a brief moment red ( = AI disconnected),
and comes back immediately.
My main GP instance which uses blackhole16 does not turn off of its red state.

But, as sayed, i run “loopback” also in the backround, which also uses blackhole16 as the out destination.
so, i turned in “loopback” the blackhole16 to off, …set also firefox as the input to off,
went back to terminal, applyed the command again.
This time that command has worked out !

  • so, i have my “for now interims solution” ! I´m ok with that for now.
    The cause seems identified. It must be related with rogue amoebas tools.
    So, thats a nice step forward !

  • next step i can try:
    i set my “System audio” as such to: blackhole16.
    so i can leave out “loopback”, and all my web-browser audio will go directly to my 2nd GP instance.

firefox has never had any audio running while the blackhole16 crash happened.

Thanks alots again ! MUCH appreciated !