How to play backing tracks and switch between rackspaces

Gig Performer 1.8.2 includes an 8 track audio file player that can be used for various purposes including playing backing tracks.

If you want to play your backing tracks independent of your main rig rackspace setup so that you can switch between rackspaces freely and not interrupt the backing track - simply create a new instance of GP just for this purpose.

Click on File->Create New Instance and name it something like “backing-tracks”. A new GP will open where you can create your rackspace, drop your Audio File Players and load your backing tracks.

You now have a completely independent backing track system that can be controlled with your MIDI or OSC devices and you can recall it any time by selecting "Open Existing Instance from the main File menu.

I was pondering this very issue this morning and this is a much better solution than I was coming up with, I was dealing with variation changes let alone rack spaces. I am glad I stopped by and saw this. Thanks.I left a video of the player out on youtube last night.

I opened up gig performer on a windows laptop and I see no create new instance under the file menu or any other menu. What am I missing?

Ah - you have to go to advanced preferences and first enable support for multiple instances.

I’m trying to setup this scenario on my Windows machine, but I have a couple of questions.

  1. I created a new instance, but I cannot tell where it is saved? Is it saved as a separate GP file, or is it only/always associated with the GP file from which I created the new instance?

  2. I am using a MIDI controller for my primary instance for VI’s and controller mapping. I then setup a new instance to use for audio files, but My MIDI controller is not an available MIDI input device for this GP instance. I would like to use my MIDI controller to control audio file playback, but I cannot figure out how to? Any ideas?

You would always open your additional instances from the main GP instance that you normally open. Thant additional instance will reopen whatever gig file you opened with it the last time. So each instance remembers its file history as well as all other settings.
This includes MIDI devices so make sure you go to Options and enable that midi device for the instance you want to use it with, but disable it for the others. This obviously applies to program change messages only - everything else is device specific regardless of the instance.

Note that on windows you may have issues with your audio driver as some do not allow multiple instances to play back at the same time, but it looks like you already created a new instance so that may not be an issue

Thanks for the reply.
I still don’t understand exactly how the additional instance is actually working. I am first asked to name the new instance which I do. Then I can independently save the “new instance” and a Save As box opens asking me where I want to save it. The New Instance seems to have 2 file names (1 that I initially give it when first created and 1 that is the actual file name that I give it when I save it).

I think I’m good with both instances sending audio correctly as I do hear audio from both at same time.

I still don’t understand how to use the same MIDI controller for both instances though. See screenshots. I enabled my MIDI controller for my New Instance, but I do not see my MIDI controller as an open when I create a MIDI input plugin in GP.

Are you on Mac or Windows? If the former, you should be able to see all your MIDI devices in all instances. However, if you’re on Windows then you can have problems depending on the particular MIDI drivers. Some don’t allow multiple applications (same as multiple Gig Performer instances) to use the same hardware ports (sigh).

As far as I know, most windows users use loopMIDI (loopMIDI | Tobias Erichsen) for this kind of thing.

Could you clarify the relationship between the original GP instance and the “new instances”? I still cannot tell exactly what the new instance is. The reason I ask is because when I create a new instance and assign it a name, the edit the new instance, then when I save the new instance, I see both file names listed in the header (both file names = the name that I assigned the new instance when creating it and the file name when I save it after it is created and edited). And if I relocate the new instance file to a new directory, my original GP project does not know the new file location.

I guess there is a slight misunderstanding of the term “instance” here. A separate GP instance is exactly as the words describe it - a separate instance running in parallel with the main one.
It (the second instance) can do anything the original instance can do including loading of any gig files, importing rackspaces etc. It will try to reload last used gig file within that instance.

Gig file that you load into the second instance is not a special gig file and you can load any other gig file into it.

Ok. Got it, thanks.

I hear noises(like LP) when i play song/audio file in instance. When i play the same song in original GP file it sounds correct. I tried different audio files. Same problem with Reaper DAW. When i try to play file in reaper, and GP is open in the same time, same noises in reaper . Just don´t know what is wrong.
Iam using Focusrite 18i8 Gen3 with Win 10 PC. Thanks a lot for any advice.

Are you using a multi client asio driver?

No, can you tell me where is the option for that ? :slight_smile: thanks a lot.

On windows when 2 programs are using the same audio interface you need a so called multi client asio driver.
Normally a hardware manufacturer delivers such a driver.
Please check if each program is set to the same sample rate in audio settings.

From the Focusrite support:

Please always select the correct device driver for your Focusrite Interface, which should read “Focusrite” or the unit’s name such as “Scarlett” “Saffire” “Clarett” etc.

As I recall, Focusrite interfaces don’t support multi-client use…

It seems indeed to be the case:

Our driver is not multi-client ASIO compatible at present, though you can run an ASIO application + as many non-ASIO applications as you wish simultaneously.

So @Manikorg, it seems it’s the end of the multiplient story for you and other focusrite users. The only option to go multiplient is probably to change your audio interface :grimacing:

Asio4all Conflicts with Focusrite driver, I uninstalled it
Also I disabled on board sound in device manager
This made my system a lot better with Focusrite audio

Hi, i suppose you uninstalled focusrite drivers and left only asio…