Help! GP 4.5.8 graphic errors on macOS 13.2.1

Hey friends,

I am having an issue using GP 4.5.8 on macOS 13.2.1 that is preventing my ability to work. I am setting up GP on this new 2023 MacBook Pro 14" and used Migration assistant to bring my data from my previous Intel MBPro. Has been working fine over the last 5 days - my GP rack spaces and setlists more or less worked but, as expected, some plugins needed to be updated. I spent half the day successfully going through rackspaces/songs and updating as needed. Then this problem started happening that brought my work to a halt.

When I right click in a wiring space, the plugin dialog briefly appears for a fraction of a second then disappears. I found if I clicked slowly I could get the window to appear normally perhaps once out of every 8 attempts (or so). Worse, the same fraction of a second behavior is occurring in the Plugin Manager window when I click either the “Manage” or “Scan” buttons - EXCEPT that I have found no way to make the dialog appear for a longer duration. Thus, this has brought my upgrade process to a halt. Do any of you have any idea what could be causing this??

I tried installing the same version of GP 4.5.8 on the same computer under a different user account (still macOS 13.2.1) and GP functions normally, so it’s not a conflict with the OS. I can’t imagine what could have caused GP to start having this error. HELP!

I think I figured it out. In System Settings/Accessibility/Keyboard/ I had inadvertently turned on “Full Keyboard Access.” I turned this off and GP seems to be working normally again. Just FYI.


What made you think of this as the cause? Seems a very strange one if a setting to do with the keyboard has an effect on double clicking and opening a window…

Or are you talking about the contextual menu?

I noticed a red rectangle appearing in finder windows, like a focus viewer. Suggested an accessibility setting to me. So I started going back through steps I had taken concerning a separate issue (giving access to Keyboard Maestro in system settings) and I saw that “Full Keyboard Access” had been toggled on. I turned it off and - voilå! When I launched GP, the issue had stopped. At least for now…