GSI VB3 Hammond - sustain pedal

I would like to use my sustain pedal (working as sustain pedal) with GSI VB3, but it is not working in the plugin out of the box.
Is there a way to trick this in GP?

I don’t have that VST but my guess is, it’s blocking sustain since traditionally organs don’t have sustain pedals and this is a bit of a purist stance (although even the hardware based Hammond XK-5 integrated sustain).

Is there a sustain parameter in the exposed list of the plugin? If so, I belive you’ll have to map a widget to it and midi map that to your pedal.

Could this make your day? :wink:

PROBLEM SOLVED
I found the solution VB3-2 Global settings. There you can define what CC64 does.

Thanks for all replies on the topic - great forum!!!

1 Like

Often organ plugins don‘t have sustain as organ don‘t have sustain, thus my Scriptlet proposal. :wink:

@madsgranum , I also use GSI VB3 II. Personally, I prefer to remap and latch the sustain pedal (CC64) to CC1. There are times where I want that sustain pedal to sustain for other instruments even when I have GSI VB3 loaded. In those cases, I will map some different controller (some slider or button) or just leave MOD (CC1) open to it. It does require a ‘little’ extra work per rackspace, but I prefer the flexibility.

X

I also use GSI VB3 II. I like to set a latching pedal that is CC64 and set the GSI VB3 II to latch the Leslie speed chorale and tremolo , thing is it doesn’t save for me , has that been an issue ? It’s one of those things I have to manually set each time I open that existing instance in my case , any work arounds anyone ?
Thanks

This setting is not part of the plugin state, so Gig performer cannot save it.
This setting must be saved within the plugin itself.
Normally the plugin save the settings when you leave the setup screen within the plugin

1 Like

ah there is a line in an .xml file that is called Settings.xml and is located at
/Users/{ your user name }/Library/GenuineSoundware/GSi VB3 II/
MIDI CC #64 Function

" MIDI CC #64 Function"

the value in parentheses must be the drop down global settings for Midi CC#64 functions
I’ll change that value “0” to “1” and report …