Grace vst template not appearing in gigperformer 4

I’ve upgrade to gigperformer4 and now all my patches that were created in the sampler Grace Vst show a blank screen when it is opened for editing. Any suggestions that would enable visual interface of plugin again? Thanks

windows 10, scarlett 4i4 interface.

Hi @JohnLawry, welcome to the family.

Does it work when you open it in GP3?

Yes it works great in GP3. I’ve actually use it a lot in GP3. Quick and easy to use and has been very reliable in GP3. Windows 10 system, Scarlett 4i4. I should add the rackspaces are being imported from my GP3 and not created on the GP4 software. When I try even starting from scratch on GP3, Grace loads but there are no editing screeens. No visual representation of any of the GUI controls. Added note, I absolutely love GP3 and GP4. I guess I’ll need to find another easy vst sampler to use and re create my sample patches. Any suggestions on a good one. It will need to be able to pitch change and play chords too. Grace vst was great and free.:slight_smile:

Hmm, there’s no reason why a plugin that worked in GP3 wouldn’t work in GP4. Have you reported the issue to the developer?

Do you have the same display settings in GP3 and GP4? Could you please check it?

I’ve just tried this plugin, the VST2 version. It has some issues:


The latest build was in 2018.

After trying to run it again, it crashed (I’ve just sent the crash report to GP devs).


I’ve also just found this info on the issues page:

Doesn’t work at all with Cubase 10

Looks like she doesn’t work at all with Cubase, is that what everyone else is seeing? Blank error box when she loads, can’t assign samples to key regions, more errors from Cubase.

I suggest that you contact the plugin developer as this plugin has problems.


The crash is clearly in the plugin, as the dialog indicates… nothing we can do

1 Like

Perhaps the right time to suggest an alternative plugin like the free version of this one:


Thanks nupudar for digging into this. Yup blank error box when loading. Same error code in GP3 but no problems running plugin and screen is visible. It appears the GP4 update has changed some of the code which impacted Grace sampler. No fault of GP4, Grace is a EOL vst. Thanks for suggestion, I will check it out.

1 Like

@JohnLawry In the Options menu, Display > Advanced tab, try changing the Graphics engine option.


1 Like

That is one cool sampler! Really easy to use.
Allthough it had the tendency to hit my CPU hard, or, I may have overstretched it by loading up all sort of samples ready to use in each rackspace…

I tried that also, no difference.

Thanks everyone for suggestions and help. I tried changing display between OpenGLl and Software Renderer early on, with no change in results. But I think I have found a possible solution. It is called Stupid Simple Sampler. Appears to be very low cpu load, 64 bit and is simple, exactly what I was looking for. I’ll need do waveform edits in another app before loading it in GP4 my preferred way of doing it anyway… I am excited to find a possible solution. . I will give an update on it after I work with it for awhile. Thanks everyone for the help, it’s greatly appreciated.

1 Like