GP not loading all IK Multimedia B-3X presets

Hello GP Community,

I recently purchased IK Multimedia’s Hammond B-3X. I’m running GP 4.5 on a Macbook Pro using
Ventura 13.5.

The issue I am having is when loaded into GP, I am only able to play one preset. When I use the program “stand alone” I’m able to access all the presets.

There are no issues when I do a scan with the plugin manager and all the presets are in a folder in the library.

Any assistance would be greatly appreciated!

Thank you in advance for any help you may offer.


Jack Prybylski

Are you using AU or VST? Try the other one and see if its any different.

Hi edm11,

Tried both with the same results.


What exactly are you doing to try to change to another preset?

Single-Clicking the bar that says "Hammond B-3X. In stand-alone mode that will produce a pull-down menu where I can choose the other presets.

Thanks dhj!

Well, I just downloaded that plugin, installed it on my Mac, instantiated the VST version and, as you can see from the gif, clicking on the presets seems to work just fine. This is with Gig Performer 4.58

Tried the VST3 and AU versions as well – clicking works just fine in all of them.

Tried it on Monterey and Ventura

Do you have any kind of mouse manager or gesture manager installed? Those things can break lots of products

2023-08-14 21-25-21.2023-08-14 21_26_14

Hi dhj,

I do not have either one of those installed. That is exactly what happens when I play the B-3X by itself.


Well, it’s not a Gig Performer issue, at least not directly.
Some possibilities to consider:

  • Mac security permissions aren’t allowing GP (and therefore the plugin) to access the folder where the presets are loaded
  • An antivirus program is preventing the plugin from accessing the presets

Thanks for your help dhj, I greatly appreciate it!

I think that this may be permissions issue. You can try this tip: [blog] Optimize your Mac for a gig - #16 by npudar


By toggling the tab that allows Gig Performer “Full Disk Access”, everything is now working correctly.

Problem solved, world saved!

My sincere thanks to edm 11, dhj, and npudar for their assistance!