GP Exception / Crashes randomly with msvcp140.dll giving an exception

When I click on a plugin to open it (couple of Arturia ones in this case), it crashes with C:\Windows\System32\msvcp140.dll being cited as giving the exception (Microsoft C++ Redistributable for Visual Studio 2015).

It doesn’t happen every time, which is strange. I’ve submitted the crash report which is where I got this module exception from, but I suspect it may be something elsse

We received your crash report and you’re right - your system is crashing with an error in msvcp140.dll… Here are the details:


Unfortunately - this has something to do with your system and not GP. Because it happens when you open a plugin - maybe look and see if an update for your graphics driver is available. There seems to be something in some of your plugins that exposes that problem.

Unfortunately - there’s nothing we can do in GP to address this or even look at it at any deeper level.

You should also report this to Arturia – we work quite closely with them, they have GP4 and might be able to reproduce if it is indeed their plugin

1 Like

Since then, I’ve run
SFC /scannow

which threw up some erros, so I ran:
DISM /Online /Cleanup-Image /RestoreHealth

Still the same culprit, so next stop, Arturia…

The file msvcp140.dll is part of the Microsoft C runtime library.

Most likely source of the problem tends to be something in the plugin. A secondary possibility is your system has an older or incompatible version of that library. Two more remote possibilities are that you’ve had some kind of malware on your system that implanted something in the dll, or your system drive (where that’s installed) is starting to experience problems and the file has become corrupted.

I’d follow up with Arturia, but you can cover the other three possibilities I listed by just going to Microsoft and downloading the current version of that runtime library.

Here’s the link to Microsoft.

1 Like

I’ve applied that but still getting the same issue. It does seem to be an Arturia plugin causing the crash, which obviously uses the VS Runtime DLL. I’ve reported it to Arturia. Thanks everyone for help and suggestions,

Incidentally, it seems to be around the Chorus Jun-6 VST3 plugin. I’ll report back on Arturia’s findings.

Arturia are aware that this is an issue in FX2 Collection of their software and recommend using VST rather than VST3. I’ll give that a go…

1 Like