GP display flashes/blinks on ONE of my Rig Manager configs

I’m running GP 4.8.2 on a MacBook Pro, 2019, 16GB RAM, Sonoma OS. I use the same laptop at home and at church, using Rig Manager to switch between the two configurations. My church setup will begin to flash/blink rapidly after about an hour or so. I’m trying to get to the culprit in all of this. My sounds will still play, but it’s almost impossible to switch to another variation or song. My setups:

Keyboard: Roland RD300NX
Controller: Korg Nanokontrol2
Interface: Focusrite Scarlett 2i2

Keyboard: Roland RD300NX
Controller: Korg Nanokontrol2
Interface: Focusrite Scarlett 18i8

I have checked all my connections to make sure nothing is loose. I use a variety of VSTs, but the same ones for both rig configurations. Any help or thoughts would be appreciated.

What precisely is flashing? From your description it could be the lights in the church😀

My entire GP window flashes rapidly. It feels like it could throw somebody with epilepsy into a seizure.

Does it flash red? Is the audio interface is disconnecting?

Does it ever happen when you are not using GP? Graphics card issue?

The flashing is white / grey. It Only happens when using GP, and no other apps or screens are affected. I’ve minimized the screen (yellow Mac window button) and brought it back, but no joy. If I close GP and open again, the issue persists.

When you create a 2nd instance and start that instance and close the main instance, does the flicker occur also?

Hmmm - thanks for the idea - haven’t tried that; I’ll do that on Sunday.

That’s bizarre — in trial mode, OR if the audio interface disconnects, we make the main window turn RED, but we don’t flash white/grey anywhere.

What version of GP are you using and from where did you get it?

1 Like

I’m using GP 4.8.2, purchased directly from the website. Been running it for over a year. BTW - I disconnected my audio interface during the flickering and still got the red screen as suspected, but the flickering continued along with the red screen.

So when did this flashing start? It really sounds like something else interfering somehow?
Do you a picture of this flashing?

Maybe try disconnecting out USB cables and see what happens?

Here’s a screenshot of the flashing - happened today.

This actually worked. The 2nd instance is behaving.

Does the issue only happen with that gig file? What happens if you start a new blank gig?

The part of the global rackspace is not flashing?

When I started a new instance it was essentially a blank template. I loaded the same Gig that was in the flashing window, and had no problems for the rest of the service, which was probably an 1.5 hours.

The part that flashes varies. At the time I took the pic it was just a portion; other times the entire window flashes.

What is the black GP rectangle at the top left of your screen?

That gray is most certainly not coming from us - it’s like something else is running and “disabling” the GP window… very strange

1 Like

The upper left is a partial view of the normal GP options in the window.

I think @dhj is taking about this :

What is this black rectangle? This is obviously not part of GP, right?