Gigperformer 'not responding'

Hi there all, new to gigperformer!

I have an i7 laptop with 48gb of ram. But i continually have issues with gigperformer freezing with windows reporting gigperformer not responding. This happens when loading, saving, changing audio set up etc. If left long enough it sometimes recovers. I am mostly using Artutia Analog Lab, with a maximum of 3 instances of the plug in. I use my korg kronos as audio out. Tried Asio4all and also Windows Audio, i get good results with windows audio, asio4all crackles and pops. Any advise would be greatly received as its becoming unuseable. Many thanks

Are you running an anti virus software?
What happens when you use another audio interface?

HI there, thanks for responding! i am (Mcafee) but i have tried stopping it. Maybe a reboot with it disabled may help. Tried different audio interface and still appear to have issues.

Yeah, definitely sounds like an anti-virus tool slowing GP down and/or blocking file access. Seen this many times.
Unfortunately, it’s often not sufficient to just disable the AV program. Sometimes you have to completely uninstall it and reboot (depends on the AV, some are better than others)

Hi. Thanks. I am using mcafee. I will try an uninstall to check. What antivirus software do you use that is gigperformer friendly?

Removed McAfee. Still have the issue. But I have now identified that one of my rack spaces when saved is 3565kb other rack spaces are around 116kb. When I remove the rack space all is well. But the problem rack space has same plugins used elsewhere with no ill effect. Anyone else seen similar problem or can advise what may be happening. Cheers

You could try using the VST3 version of the plugin instead of VST? (or the other way around)

What is the plugin you referring to?

This has become the new ‘have you tried turning it off and on again’ :wink: But like the original phrase, it usually works!

In general though, it is the case that something external is holding things up such as

  • AV blocking/slowing down file access while it examines it (imagine hat when you have large gig files full of process state)
  • Plugins trying to connect to a server
  • Plugin being blocked by AV
  • Malware that crashes a plugin or just corrupts GP itswlf

We’ve seen all of these

Hi I am using Arturia Analog Lab 4 vst3. For some reason the rack has a very large size (compared to others). I have deleted the rack and recreated and all is ok now. But would be good to understand why such a large file was created.

GP asked each plugin for its “state” which is then saved as part of the gig file. When loading a gig, GP sends that state back to the plugin, so that you get exactly the same sounds back when you load a gig.

Arturia Lab must be supplying a huge amount of state information.

Thanks very much for your thoughts. I recreated the rackspace and it now appears to be of usual size. So will see if it happens again!. Thanks again.

1 Like