Gig Performer 3 keeps disconnecting audio interface

I have a problem with audio interface (Roland FA-06) being disconnected frequently.
I have tried several different cables but the problem never goes away. The same audio interface has a rock solid connection in every other program.
(Cubase, Ableton and Pro Tools)

Some more info please:
Mac or win… what versions of OS, what drivers used?

Are you using the Demo-Version?

1 Like

This was exactly my first thought too…
When in demo mode (within the trial period), there are short periodic dropouts happening (this is by purpose). As soon as the software is fully licensed, the dropouts will be gone.

1 Like

Oh, no, the demo mode again! :stuck_out_tongue_winking_eye:


No demo. Using version 3.7.

If I was using a demo version I would have expected a strange behavior. I am using Gig Performer 3.7 and have purchased both a windows version and a Mac version.

The more details you can provide the better.
Does GP flag it as disconnected in the title/header area?
Does it reconnect immediately or do you have to physically disconnect the interface or close/reopen GP?
Does it do this while playing or after a period of inactivity?
Do you use a usb hub?
Your OS/version?

The screen turns red and says audio interface is disconnected. I have to restart GP to get it working. This is happening during playing. I have it connected directly to the computer (Windows 10)

Someone else could confirm, but the only ‘red screen’ I’ve ever seen in GP is the one that occurs during trial mode that pauses the audio every 20 minutes. Sorry for the basic question, but you’ve definitely activated your version of GP?

You will get a red screen telling you that your audio device got disconnected if you pull out a cable or power down your audio interface while GP is using it.
This is a feature and allows you to reconnect the interface, live, without having to restart anything and keep playing. More than once it happened to use that someone pulls or steps on your cables by accident.

@bjornsjoflot there are other threads with similar issue and they all got resolved with a good quality power USB hub. Some interfaces are a little fussy about those.

It should not be necessary to use a powered usb-hub when the interface is power it self. This is way to silly! GP is the only program I have been using that acts this way. All the others is problem-free!

Yeah, that’s a great feature of GP. This kind of situation killed me when I was using Cantabile. That’s why I am surprised that @bjornsjoflot has to restart GP to make everything work again.

@bjornsjoflot, I guess we could suspect:

1) the audio interface audio driver

  • Do you encounter the same issue on Win and Mac ?
  • On Win you could try the ASIO4ALL for testing purposes ?
  • On Win is your driver multiclient? (can you use GP together with a DAW or several GP instances?

2) the powered (!) USB HUB if you use one

  • Change it, check the power supply or try a direct connection
  • Could it be double powered?(perhaps it dislikes USB+power supply)

3) the USB cable

  • I already had a similar issue, but it seems you tried several -good quality?- cables, right?

4) the audio interface itself? :thinking:

  • Any control/power LED for diagnose purposes?

What happens if you disconnect the audio interface and reconnect it a bit later? As explained by @djogon, GP is supposed to detect it when it is reconnected and go on working normally.

I had already encountered this problem when I started using my Roland FC300 and experimenting.
I first had no problem using a midi to usb converter.
Then I had several red screen with the FC300 connected to my Steinberg UR22 midi port. In this case, reconnectig without restarting worked fine.
But maybe the problem laid elsewhere. In any case, I have not found the source of the problem.
I do not have any problems now, using alternatively the FC300 through the UR22 or a pedalboard through usb connection box, thanks to the rig manager.

Agreed - we’re pointing out that if you do use a hub - try another one. IF you are connecting directly to a computer - try another port.

Which firmware version do you have for FA-06? I assume you did install the specific Windows 10 driver. Do you have an alternative computer to try it on?

So, here’s the way I think about this. First of all, if Gig Performer is reporting a disconnection, then you are getting disconnections. Why that’s happening is unclear but it should be viewed as a warning that there is something wrong somewhere. It could be a hardware, firmware, device driver issue, anti-virus interruption (don’t laugh, we’ve seen that before) or something else.

In a DAW, maybe it’s harmless (so far) but also, if something is going to fail at some point, failing in the studio is not a big deal, you can always re-record whatever was being recorded.

On the other hand, if you’re up on stage, you do not want your system dying on you!

1 Like

I’m getting exactly the same with a Roland Studio-Capture device. Windows sees my device connected, but GigPerformer does not. I’ve changed the cable and port but the same occurs unless I restart my PC.

It seems that the ASIO driver of this audio interface is not multi-client. Could it be that Windows already uses it, such that it is no more available for GP? :thinking:

I’ve never had a problem before, but I managed to use the ASIO4ALL driver and map that. Had to tweak to fix latency, but seems to work.

Do you need a multi-client driver? e.g. to run GP and a DAW or several GP instances at the same time? If not I would rather use the Roland driver for GP and prevent Windows to use it for the system sound. The latency if the ASIO4ALL driver is not really optimal for live use… But OK, if you managed to work with it.