GGD Zilla acting strangely

I received my copy of GGD Zilla a few days ago and am very happy with the sounds I am getting.

However, the performance of the plugin on my Macbook Pro 2017/16GB GP3.8 is not great.

The AU Plugin doesn’t load in GigPerformer (failed to initialise)

The VSt3 Plugin works, but it is performing strangely, sometimes Audio just cuts out when I switch to the rack space of the plugin or try to load a new cab or preset, and it seems to fully block the output of my Apogee JamPlus. Sometimes sound comes back after a few seconds, which can be up to like 20 seconds, sometimes it stays mute. In this case I need to restart my Mac to get things running again. If I switch to a different rackspace in GigPerformer, which disables the GGD Plugin, I get Audio back. There seem to be some processes that slow down the computer or some incompatibility? Anyone else any experiences with GGD?

Does it appear in the PluginManager window at the bottom in red?

Hi Paul,

yes, at the bottom, and in red

What version of GP are you using?

Hi Paul,

3.80 is what I am using and latest GGD/Zilla

The VST version os working fine?
VST3 Version does not?
And AU is not validated?

Any chance to test this plugin versions in another DAW?

No. Both VST versions have this behaviour (VST or VST3) and the AU doesn’t validate.

Have you tried re-scanning it (use the Scan->Re-scan failed plugins)?
Have you tried some other DAW as @pianopaul suggested?


Ok I rescanned all Plugins, but it didn’t make a difference. Rescanned failed plugins, no difference.

The AU version shows up and works flawlessly in Logic Pro. I can load presets and it takes just a second to load even the largest presets with 8 IRs in Logic, no problem. It seems to be an issue if I try to load larger presets with more than 2 or 3 IRs in GP, then it hangs, and the rackspace gives a clicking sound like disabling the output. I still get levels in the meters, but the output is dead and cannot be gotten back even if I remove the GGD plugin from that rack space. The other rackspaces in the gig file still work. It’s the same on my 2 different interfaces (Apogee and IK Multimedia) as well as the internal audio.

Hmmm. It is strange that the VST2/3 versions of the plugin would behave so differently.
Do you have the same audio settings? These are Its which means you have to be careful about the sample rate. Do you have the same sample rate in both Logic and GP?

Could you contact GGD and report this issue to them. It also does not make sense that the AU edition of the plugin cannot be validated unless its 32bit only or something else out of the ordinary and supported only by Apple.

This is very similar to what I was getting with another IR plugin (faIRmageddon by forward audio). But I was able to replicate it in Reaper and reported it to their dev. It’s now been fixed and works correctly in GP.


I did report it to them. Let’s see.

Just to be clear: VST2 and VST3 both have the same issue. Only difference between the two is that VST2 shows 2 inputs, whereas VST3 only shows one.

Sample rates were all 44.1 in GP and Logic when I tested today. The IRs in the Plugin might be recorded in a higher Sample rate likely

In the case of faIRmagedon it was related to mono/stereo as the clicking and disabled output would always occur if I had the IRs internally panned hard left or right (only outputting on 1 channel). And it also caused problems with particular plugins after it like Valhalla Room and bx_rooms. But thankfully all fixed now.

1 Like

Thanks for sharing your experience. Yeah Torpedo WOS also used to be weird, it has worked then since 3.8 update.

Somehow I managed to make it work, now GP is crashing sometimes, which I prefer, because I don’t need to restart the whole Mac. :wink:

Do you have a crash report?

Yes I did send some. Where can I find them on my Mac?

try cmd+spaceBar write Console

Not sure if they stay here:

User Reports

Normally on Mac this report is shown automatically from the crash reporter.

I got the report from @jaeger and his AmpliTube4 is crashing as can be seen from his crash report

Thread 123 Crashed:
0   com.ikmultimedia.vpa.AmpliTube 4	0x0000000139e6067d IK::Products::AT4::MainDocument::OnIdle() + 797
1   com.ikmultimedia.vpa.AmpliTube 4	0x0000000139fc405b 0x139dbd000 + 2125915
2   com.ikmultimedia.vpa.AmpliTube 4	0x000000013a70a688 IK::ATK::DocViewUtils::LockingScheduler::ProcessActivationQueue() + 552
3   com.ikmultimedia.vpa.AmpliTube 4	0x000000013a21cf5c 0x139dbd000 + 4587356
4   libsystem_pthread.dylib       	0x00007fff6344b2eb _pthread_body + 126
5   libsystem_pthread.dylib       	0x00007fff6344e249 _pthread_start + 66
6   libsystem_pthread.dylib       	0x00007fff6344a40d thread_start + 13