External MIDI sync


Hi guys,

I am new to GP but have a problem with external syncing to a MIDI clock. Ticking the “external sync” button allows a MIDI clock from Cubase 9.5 to set the tempo of GP 2.6. But the stability is not very good to say the least! The BPM continually moves + / - 2 bpm. Also, if I tick the “sync time” button I am expecting it to follow the time signature from Cubase as well? It doesn’t. Now, it might be me not understanding things correctly! Is anyone else trying to do this?




Midi clock cannot transmit anything but the tempo. Time signature is not transmitted.
If the clock moves by a lot all the time the clock source is most likely unstable.
Because you are on Windows and this is not a hardware clock - how is your Cubase sending this clock via MIDI? Do you use some kind of midi loopback driver? If so - this is most likely the source of the instability.
You could try to decrease the buffer size in GP/Cubase to say 128 samples (if it is higher than that now) and see if that helps a bit.



Thanks for your response. Cubase is sending the MIDI clock via a standard MIDI port on an iConnectivity MIO10. I can sync other things via the same route with a rock-solid clock.

So what is the tick box “sync time” in reference to?

Thanks again,



There is a “Sync” checkbox ant “Set time” checkbox - they are different.


The “Set time…” checkbox will make your global tempo and time signature change when you switch to this rackspace. Otherwise the time information will not change and will stay at the global settings.

The “Sync…” checkbox means that this rackspace will react and adjust to external MIDI clock.



Thanks again for your quick response … and my understanding of the “set time info” button was incorrect as I suspected.



No problem… just remembered that an often overlooked source of MIDI clock issues is having two midi clocks somehow running in your environment or one of the devices is “repeating” the clock within the system creating two separate midi events. For MIDI clock to work properly there has to be only one within the entire rig.


Great insight … it is possible there is a MIDI clock issue with my current setup. I will need to investiage some more.

Many thanks